6

I'm a beginner with Ubuntu. I installed Ubuntu 14.04 on my Acer Aspire E11, and I have an issue with my bluetooth. The thing is it's not finding other devices and other devices can't find it.

I ran : ~$ dmesg | grep -i blue and here is the output

[   10.787194] Bluetooth: Core ver 2.17
[   10.787226] Bluetooth: HCI device and connection manager initialized
[   10.787237] Bluetooth: HCI socket layer initialized
[   10.787241] Bluetooth: L2CAP socket layer initialized
[   10.787248] Bluetooth: SCO socket layer initialized
[   16.114685] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   16.114692] Bluetooth: BNEP filters: protocol multicast
[   16.114705] Bluetooth: BNEP socket layer initialized
[   16.168530] Bluetooth: RFCOMM TTY layer initialized
[   16.168547] Bluetooth: RFCOMM socket layer initialized
[   16.168557] Bluetooth: RFCOMM ver 1.11

It looks fine but It's not detecting anything.

1
  • Please edit your question and add output of lspci -knn | grep Net -A2; lsusb terminal command. – Pilot6 Feb 14 '16 at 19:25
6

This solution worked for me

I am happy to report that I have solved the problem using the workaround given on a bug report as follows:

  1. Boot into Windows 7/8.
  2. Turn off the Bluetooth/Wireless switch from within Windows.
  3. Reboot and boot into Linux
  4. Turn on the wireless switch.

This solution ensures that bluetooth and wireless now work.

Discovered the workaround here

2
  • But I removed windows what can be done now? – a-c-sreedhar-reddy Dec 14 '18 at 21:33
  • This solved my problem with W10 & Ubuntu 20.04 too. Dual boot with Windows causes unnecessary troubles all the time. It's really hard to believe that these issues are happening by coincidences, or all by Linux driver issues... – Orhan G. Hafif Nov 17 '20 at 13:56
3

Try the following

sudo mv /etc/bluetooth /etc/bluetooth.backup

sudo apt-get install --reinstall bluez

After a reboot check the issue. The /etc/bluetooth directory should be empty now.

If this does not work for you, just move back the bluetoth.backup directory to it's original place.

(or)

Missing Firm-ware could also be an issue and you can fix it with the command

sudo apt-get install linux-firmware

Hope this helps!

3
  • I already have the linux-firmware installed so I don't think it's the issue – UHMIS Nov 1 '14 at 1:47
  • I tried this, but it doesn't help – UHMIS Aug 16 '15 at 5:24
  • In Debian 9, I wasn't not able to enable Bluetooth. I fixed my issue by re-installing bluez as your suggestion in first part of the answer. After rebooting, it worked. – Ajeeb.K.P Jan 7 '18 at 14:55
1

upgrading the kernel from 3.13 to 3.16 solved the issue for me LTSEnablementStack

1
  • 1
    I tried to upgrade using: sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid but it is giving me: a bunch of not installable stuff and at the end E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. What else can I do? – UHMIS Aug 16 '15 at 5:21
1

Basically when there is a hardware change, ubuntu doesn't automatically pick up the new hardware and make it running. So just like the accepted answer, if you turn off wifi/bluetooth with the hardware switch in any other operating system than ubuntu, it makes ubuntu think that these devices aren't there are boot up, and so when you turn them on, it loads the appropriate drivers.

Another way of achieving the same effect without having to reboot or anything would be to edit this file: /etc/bluetooth/main.conf, it will probably require sudo, hence:

sudo gedit /etc/bluetooth/main.conf

And then go to the bottom of the file and uncomment #AutoEnable=false and make it AutoEnable=true.

This essentially tells Ubuntu to load drives even for those devices that are found after booting (hence achieving the effect of a reboot with hardware switch turned off).

Once you save the file, simply restart the service with:

sudo systemctl restart bluetooth.service

And Bluetooth should now be working fine.

I basically swapped my M.2 Sata chip from one computer to another computer and surprisingly enough everything worked nicely minus the wifi and bluetooth. The above solution worked for me.

0

This seemed to work (I don't have windows to switch to).

  1. Halt (not warm reboot)
  2. Wait like 30 to ensure all devices to lose power.
  3. Reboot

I tried rfkill first but there were no soft blocks. Ref: other bluetooth issue

rfkill list
0

I had success with a solution similar to the accepted answer. I booted into Ubuntu with a Live CD and enabled Bluetooth. After a reboot it also worked on my installed Ubuntu (kernel version 3.19)

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.