5

I recently installed Xubuntu 14.04 and I noticed that it had Ctrl+F1...etc assigned to switch workspaces.

This is very annoying since Ctrl+F4 is for closing tabs in my browser and I use it a lot.

In old XFCE in 12.04 I had it set to Super+1...etc to switch workspaces.

So I went to Settings -> Window Manager to change it. I changed the keyboard bindings to this:

enter image description here

And it worked, till I rebooted.

Once I rebooted the next day my keybindings were right back at Ctrl+F1 even though the settings screen shows different. This screenshot is from right now, and those key bindings aren't working. If I press Super+2 nothing happens, if I press Ctrl+F2 it switches to Workspace 2. Even though, as you can see from the screenshot, it is set to the super key.

What gives with the new XFWM?

2
+50

Might be this bug Window manager keybindings don't work after reboot:

Steps to reproduce:

Use Settings -> Window Manager to rebind a key (e.g. rebind super + m to maximize window ) It should work fine Reboot The keybinding is no longer recognized. Going into settings -> Window Manager the UI still claims that it is configured, but the setting doesn't work unless the key is manually rebound again.

While it is still worked on and not resolved yet, there are some workarounds:

  • clear before reassign:

    Select an action you want to reassign and click 'Clear' button until it will really empty. Sometime if there is some (hidden?)duplicates, you will still see some shortcut(the same or different), even you clicked 'Clear' button. In this case just click the button again. Since the action shortcut is really empty, just assign your custom one as usual, and it will work ok :)

  • delete mapping twice

    You simply have to delete the current key mapping twice before setting a new one. Then the new mapping will be stored in the config.

There is a similar bug related to CompizConfig Settings Manager, but I don't think that it applies to your setup. This particular bug however is fixed and available in the trusty-proposed repository (How do I add the "proposed" repository? on how to enable this repository).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.