2

I had created a bootable hackintosh usb stick but I found that I had a problem that could be solved by renaming a file or editing another. But the usb stick was read only and, in a moment of stupidity, I became root and edited /etc/fstab so that:

error=remount-ro

under dev/sda5 became:

error =remount-rw

As a result, when I rebooted the pc, it refused to boot. The drive is now mounted read-only and, as a result, I cannot change the rw back to ro. Can anyone help me change etc/fstab back and maybe help me edit the file on the bootable usb?

6
+50

I mounted the partition using mount -o remount,rw /dev/sda5 / in the Ubuntu recovery terminal and then edited the file to fix the problem. I restarted the computer and that fixed it.

  • If something is already mounted, it's enough to specify either the device or image file to mount (/dev/sda5) or the mount point directory (/). Passing both as argument seems not to hurt, but is superfluous. – Byte Commander May 19 '16 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.