57

I tried installing ttf-mscorefonts-installer from the terminal, because I want to use Wine.

It looked kind of like it failed on the Comic Sans part. Viewing it just displays the text in another font.

Then this Failure to download extra data files window popped up.

enter image description here

I tried uninstalling ttf-mscorefonts-installer from the terminal and then reinstalling it by following the instructions in this answer. This time it failed to fetch the first font, andale32.exe. I got an error message that said: invalid content-range header.

What should I do?

  • Curiously I tried downloading the Adele TTF but it looks like it was rolling in the deep because I could not download it. Rumor has it that if I take it all I'll be able to download it. So I'll be waiting. – Luis Alvarado Dec 23 '16 at 14:49
70
+100

Same problem, found a solution

  1. Install the package ttf-mscorefonts-installer, we need some things from the package later

    sudo apt-get install ttf-mscorefonts-installer
    
  2. Download and install the fonts

    TMP=$(mktemp -d)
    cd "$TMP"
    awk '/Url/ {system("wget "$2)}' /usr/share/package-data-downloads/ttf-mscorefonts-installer
    sudo /usr/lib/msttcorefonts/update-ms-fonts "$TMP"/*
    
  3. Avoid future error message

    sudo touch /var/lib/update-notifier/package-data-downloads/ttf-mscorefonts-installer
    
  4. Housekeeping

    cd ..
    rm -r "$TMP"
    

primary source

Problem solved ;)

  • 2
    Seems to have worked perfectly for me on Ubuntu 16.04. Thank you for providing such a clear answer with copy and paste ready instructions. – TafT Nov 17 '16 at 15:17
  • 2
    Just tested this on Ubuntu 16.04 and works perfect! – Terrance Jan 9 '17 at 17:07
  • Can you explain what you are doing with these commands, and why? – Todd Chaffee Jan 25 '17 at 0:43
33

I fixed it.

Download and install this via software-center and boom! It's working :D

  • 1
    Is this still the case in 2016? – MrMesees Nov 25 '16 at 12:30
  • 2
    @MrMesees, I think so. I'm running 16.04 and bumped into this problem on my last update. – rsuarez Dec 7 '16 at 8:14
  • Didn't solve the problem for me on Ubuntu 17.10 – Ciske Boekelo May 3 '18 at 14:48
9

A straight-forward option work-around can be implemented as follows using a Debian repo (reliable):

sudo apt-get -y remove --purge ttf-mscorefonts-installer
wget http://ftp.de.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb -P ~/Downloads
sudo apt install ~/Downloads/ttf-mscorefonts-installer_3.6_all.deb

Hopefully, the Ubuntu repo version will be fixed soon.

  • 2
    This is the only workaround that actually worked for me (January 2017), thanks! – Milan Jan 4 '17 at 16:05
2

As for a freshly set up Ubuntu 64-bit 15.04 with all extras also installed during installation, Wine stopped half-ways in the process, and it was connected to the mscorefonts, with the repeated error message given above. After waiting some hours, I quit the software center, and rebooted. The following lines cured the problem completely and set up the mscorefonts correctly, as far as I can tell. Explanation is given underneath.

sudo apt-get update --fix-missing
sudo dpkg --configure -a
cd
sudo wget downloads.sourceforge.net/corefonts/andale32.exe
sudo wine andale32
rm andale32.exe

The first line tells that the second line (the dpkg) has to be performed, to complete wine installation. Then, when this takes places, it tells that andale32.exe is not as expected (in hash value, which probably refers to an earlier version of it or such). Assuming that it is okay, it is then manually installed, in this case by running 'sudo' in front of wine, which may not be necessary. After the final line and a wait, the question of whether to accept the fonts arises as a nice window. A repeat of the --fix-missing reports no need for additional commands.

1

To fix this try removing and re-installing ttf-mscorefonts-installer from the terminal only - there are some prompts which need to be answered, and are not always done properly in a graphical window:

Open a terminal with alt+ctrl+t

Enter the following commands

sudo apt-get remove --purge ttf-mscorefonts-installer
sudo apt-get install ttf-mscorefonts-installer

Not the answer you're looking for? Browse other questions tagged or ask your own question.