9

I've read other questions in askUbuntu, but couldn't solve the problem as I'm new to Linux.

The problem is that the Wifi connection on Ubuntu 14.04 is unstable. It does connect to wifi for a while, but after 5 minutes it just cannot find most of the networks(it does find some of them).

I just bought it from Mouse Computer. But it is stable in Windows 8.1(dual boot) so seems not a hardware problem.

I've tried the solutions below.

  1. Add "options iwlwifi 11n_disabled=1" in /etc/modprobe.d/iwlwifi.conf

  2. Ignore IPv6

  3. Restart NetworkManager

None of them solved the problem.

Below follows the information of my Ubuntu.

    ======== Wireless-Info START ========

System-Info ~~~~~~~~~~~~~~~~~~~~~~~~

yuu 3.13.0-37-generic x86_64,  Ubuntu 14.04.1 LTS, trusty

CPU    : Intel(R) Core(TM) i7-4712MQ CPU @ 2.30GHz
Memory : 15971 MB
Uptime : 21:43:43 up  1:48,  1 user,  load average: 0.05, 0.05, 0.05


lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
    Subsystem: QUANTA Computer Inc Device [152d:0999]
    Kernel driver in use: r8169
--
09:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:b729]
    Kernel driver in use: rtl8723be


lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 0bda:b002 Realtek Semiconductor Corp. 
Bus 003 Device 007: ID 058f:6387 Alcor Micro Corp. Flash Drive
Bus 003 Device 002: ID 5986:0523 Acer, Inc 
Bus 003 Device 006: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~



iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off



rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Interface        Soft blocked  Hard blocked
1: phy0: Wireless LAN      no            no
2: hci0: Bluetooth         no            no


lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

iwlwifi               169932  0 
rtl8723be              85118  0 
btcoexist              50304  1 rtl8723be
rtl8723_common         23361  1 rtl8723be
rtl_pci                26690  1 rtl8723be
rtlwifi                63475  2 rtl_pci,rtl8723be
mac80211              630653  3 rtl_pci,rtlwifi,rtl8723be
cfg80211              484040  3 iwlwifi,mac80211,rtlwifi
wmi                    19177  0 


module parameters ~~~~~~~~~~~~~~~~~~

cfg80211      (2): cfg80211_disable_40mhz_24ghz=N | ieee80211_regdom=00
iwlwifi      (11): 11n_disable=1 | amsdu_size_8K=0 | antenna_coupling=0 | bt_coex_active=Y | fw_restart=Y | led_mode=0 | nvm_file=(null) | power_level=0 | power_save=N | swcrypto=0 | wd_disable=1
mac80211      (5): beacon_loss_count=7 | ieee80211_default_rc_algo=minstrel_ht | max_nullfunc_tries=2 | max_probe_tries=5 | probe_wait_ms=500
rtl8723be     (6): debug=0 | fwlps=Y | ips=Y | msi=N | swenc=N | swlps=N
wmi           (2): debug_dump_wdg=N | debug_event=N


nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

State: disconnected
================o=============o===========o==============o=========o===========o==============o===========
 Interface & ID | Type        | Driver    | State        | Default | Speed     | Support      | HW Addr   
================o=============o===========o==============o=========o===========o==============o===========
 wlan0          | 802.11 WiFi | rtl8723be | disconnected | no      |           | WEP/WPA/WPA2 | <MAC wlan0>

    supermolecule:   Infra, <MAC C-NA supermolecule 1>, Freq 2447 MHz, Rate 54 Mb/s, Strength 60 WPA2
    001D73B28EFB:    Infra, <MAC C-NA 001D73B28EFB 1>, Freq 2422 MHz, Rate 54 Mb/s, Strength 77 WPA WPA2
----------------+-------------+-----------+--------------+---------+-----------+--------------+-----------
 eth0           | Wired       | r8169     | unavailable  | no      |           |              | <MAC eth0>
----------------+-------------+-----------+--------------+---------+-----------+--------------+-----------


NetworkManager.state ~~~~~~~~~~~~~~~
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true


NetworkManager.conf ~~~~~~~~~~~~~~~~

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false


NM WiFi Profiles ~~~~~~~~~~~~~~~~~~~

106F3FF45FE8         : ssid=106F3FF45FE8 | mac-address=<MAC wlan0> | ipv4=auto | ipv6=auto 
15403                : ssid=15403 | mac-address=<MAC wlan0> | ipv4=auto | ipv6=auto 
utroam               : ssid=utroam | mac-address=<MAC wlan0> | ipv4=auto | ipv6=auto 
utroam-1x            : ssid=utroam-1x | mac-address=<MAC wlan0> | ipv4=auto 


interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

resolv.conf ~~~~~~~~~~~~~~~~~~~~~~~~



Routes & Ping ~~~~~~~~~~~~~~~~~~~~~~

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface


iw reg get ~~~~~~~~~~~~~~~~~~~~~~~~~

(Region : ja_JP.UTF-8)
country 00:
    (2402 - 2472 @ 40), (3, 20)
    (2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
    (5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS


iwlist chan ~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     13 channels in total; available frequencies :
          Channel 01 (2.412 GHz) - 13 (2.472 GHz)


iwlist scan ~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     No scan results


blacklist ~~~~~~~~~~~~~~~~~~~~~~~~~~

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci


modinfo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[iwlwifi]
filename:       /lib/modules/3.13.0-37-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
version:        in-tree:
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-7265-7.ucode
firmware:       iwlwifi-3160-7.ucode
firmware:       iwlwifi-7260-7.ucode
srcversion:     C2D0F3DFCA289585C100E36
depends:        cfg80211
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size_8K:enable 8K amsdu size (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable, 2=enable (default: 0) (int)
parm:           nvm_file:NVM file name (charp)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)

[rtl8723be]
filename:       /lib/modules/3.13.0-37-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw.bin
srcversion:     0D59E0301AAA6E5A93400BB
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
parm:           swlps:bool
parm:           swenc:using hardware crypto (default 0 [hardware])
parm:           ips:using no link power save (default 1 is open)
parm:           fwlps:using linked fw control power save (default 1 is open)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
parm:           debug:Set debug level (0-5) (default 0) (int)

[btcoexist]
filename:       /lib/modules/3.13.0-37-generic/kernel/drivers/net/wireless/rtlwifi/btcoexist/btcoexist.ko
srcversion:     3CC61E00E2CEF446293F879
depends:        

[rtl8723_common]
filename:       /lib/modules/3.13.0-37-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723com/rtl8723-common.ko
srcversion:     D1807280DBDC9B8A7EBDAB7
depends:        

[rtl_pci]
filename:       /lib/modules/3.13.0-37-generic/kernel/drivers/net/wireless/rtlwifi/rtl_pci.ko
srcversion:     D5E4890DC428FA5A1BF92DF
depends:        mac80211,rtlwifi

[rtlwifi]
filename:       /lib/modules/3.13.0-37-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
srcversion:     E1F4663325225EE8DBA54CA
depends:        mac80211,cfg80211

[mac80211]
filename:       /lib/modules/3.13.0-37-generic/kernel/net/mac80211/mac80211.ko
srcversion:     B822641624778B987844F6F
depends:        cfg80211
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/3.13.0-37-generic/kernel/net/wireless/cfg80211.ko
srcversion:     C2478077E22138832B71659
depends:        
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

[wmi]
filename:       /lib/modules/3.13.0-37-generic/kernel/drivers/platform/x86/wmi.ko
srcversion:     CED5410F008DC70DF5F064B
depends:        
parm:           debug_event:Log WMI Events [0/1] (bool)
parm:           debug_dump_wdg:Dump available WMI interfaces [0/1] (bool)


udev rules ~~~~~~~~~~~~~~~~~~~~~~~~~

# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10ec:0xb723 (rtl8723be)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC wlan0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"


Custom files/entries ~~~~~~~~~~~~~~~

/etc/modules        : Default
/etc/rc.local       : Not Default
/etc/modprobe.d     : Not Default
/etc/pm/(cnf|pw|sl) : Not Default

[/etc/rc.local]
echo 1100 > /sys/class/backlight/intel_backlight/brightness
exit 0

[/etc/modprobe.d]
iwlwifi.conf      : remove iwlwifi \
                    (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
                    && /sbin/modprobe -r mac80211
                    options iwlwifi 11n_disable=1
iwlwifi.conf~     : remove iwlwifi \
                    (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
                    && /sbin/modprobe -r mac80211
mlx4.conf         : softdep mlx4_core post: mlx4_en

[/etc/pm/power.d/wireless]
#!/bin/sh

/sbin/iwconfig wlan0 power off


Kernel boot line ~~~~~~~~~~~~~~~~~~~

BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic.efi.signed root=UUID=ee1f131b-08b0-429f-8912-7a3f287c793b ro quiet splash vt.handoff=7


dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[    0.621462] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[    0.621709] audit: initializing netlink socket (disabled)
[    0.790834] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    1.357364] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x461f16)
[    2.766506] wmi: Mapper loaded
[    2.826782] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
[    2.839363] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[    2.839551] rtlwifi: wireless switch is on
[    4.546965] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    5.190130] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    5.190320] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   90.622664] wlan0: authenticate with <MAC ID removed>
[   90.641893] wlan0: send auth to <MAC ID removed> (try 1/3)
[   90.643488] wlan0: authenticated
[   90.645396] wlan0: associate with <MAC ID removed> (try 1/3)
[   90.648479] wlan0: RX AssocResp from <MAC ID removed> (capab=0x631 status=1 aid=2)
[   90.648488] wlan0: <MAC ID removed> denied association (code=1)
[   90.667814] wlan0: deauthenticating from <MAC ID removed> by local choice (reason=3)
[   90.794241] wlan0: authenticate with <MAC ID removed>
[   90.804439] wlan0: send auth to <MAC ID removed> (try 1/3)
[   90.820868] wlan0: authenticated
[   90.821302] wlan0: associate with <MAC ID removed> (try 1/3)
[   90.826483] wlan0: RX AssocResp from <MAC ID removed> (capab=0x431 status=0 aid=1)
[   90.826668] wlan0: associated
[   90.826688] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   90.830500] wlan0: deauthenticated from <MAC ID removed> (Reason: 3)
[   92.261378] wlan0: authenticate with <MAC ID removed>
[   92.280916] wlan0: send auth to <MAC ID removed> (try 1/3)
[   92.282342] wlan0: authenticated
[   92.284475] wlan0: associate with <MAC ID removed> (try 1/3)
[   92.287446] wlan0: RX AssocResp from <MAC ID removed> (capab=0x431 status=0 aid=1)
[   92.287733] wlan0: associated
[  106.832962] wlan0: authenticate with <MAC ID removed>
[  106.843208] wlan0: send auth to <MAC ID removed> (try 1/3)
[  106.848511] wlan0: authenticated
[  106.852023] wlan0: associate with <MAC ID removed> (try 1/3)
[  106.859249] wlan0: RX AssocResp from <MAC ID removed> (capab=0x431 status=0 aid=2)
[  106.859404] wlan0: associated
[  548.150121] wlan0: authenticate with <MAC ID removed>
[  548.160402] wlan0: send auth to <MAC ID removed> (try 1/3)
[  548.178327] wlan0: authenticated
[  548.181277] wlan0: associate with <MAC ID removed> (try 1/3)
[  548.189450] wlan0: RX AssocResp from <MAC ID removed> (capab=0x431 status=0 aid=1)
[  548.189625] wlan0: associated
[  558.311342] wlan0: authenticate with <MAC ID removed>
[  558.321619] wlan0: send auth to <MAC ID removed> (try 1/3)
[  558.323667] wlan0: authenticated
[  558.326548] wlan0: associate with <MAC ID removed> (try 1/3)
[  558.329850] wlan0: RX AssocResp from <MAC ID removed> (capab=0x431 status=0 aid=2)
[  558.330015] wlan0: associated
[ 1091.372951] wlan0: deauthenticating from <MAC ID removed> by local choice (reason=3)
[ 1094.309771] rtlwifi: wireless switch is on
[ 1097.560361] rtl8723be 0000:09:00.0: no hotplug settings from platform
[ 1098.357498] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1100.059861] wlan0: authenticate with <MAC ID removed>
[ 1100.079734] wlan0: send auth to <MAC ID removed> (try 1/3)
[ 1100.082123] wlan0: authenticated
[ 1100.083299] wlan0: associate with <MAC ID removed> (try 1/3)
[ 1100.086300] wlan0: RX AssocResp from <MAC ID removed> (capab=0x431 status=0 aid=4)
[ 1100.086474] wlan0: associated
[ 1100.086510] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1100.251871] wlan0: deauthenticating from <MAC ID removed> by local choice (reason=2)
[ 1100.285453] wlan0: authenticate with <MAC ID removed>
[ 1100.295648] wlan0: send auth to <MAC ID removed> (try 1/3)
[ 1100.298036] wlan0: authenticated
[ 1100.299060] wlan0: associate with <MAC ID removed> (try 1/3)
[ 1100.302358] wlan0: RX AssocResp from <MAC ID removed> (capab=0x431 status=0 aid=4)
[ 1100.302519] wlan0: associated
[ 1126.163709] wlan0: authenticate with <MAC ID removed>
[ 1126.173858] wlan0: send auth to <MAC ID removed> (try 1/3)
[ 1126.175735] wlan0: authenticated
[ 1126.179692] wlan0: associate with <MAC ID removed> (try 1/3)
[ 1126.195366] wlan0: RX AssocResp from <MAC ID removed> (capab=0x431 status=0 aid=2)
[ 1126.195526] wlan0: associated
[ 1204.358127] wlan0: authenticate with <MAC ID removed>
[ 1204.368261] wlan0: send auth to <MAC ID removed> (try 1/3)
[ 1204.370628] wlan0: authenticated
[ 1204.373013] wlan0: associate with <MAC ID removed> (try 1/3)
[ 1204.376126] wlan0: RX AssocResp from <MAC ID removed> (capab=0x431 status=0 aid=4)
[ 1204.376283] wlan0: associated
[ 1314.956600] wlan0: authenticate with <MAC ID removed>
[ 1314.966758] wlan0: direct probe to <MAC ID removed> (try 1/3)
[ 1315.167841] wlan0: direct probe to <MAC ID removed> (try 2/3)
[ 1315.371627] wlan0: direct probe to <MAC ID removed> (try 3/3)
[ 1315.575434] wlan0: authentication with <MAC ID removed> timed out
[ 1316.655061] wlan0: authenticate with <MAC ID removed>
[ 1316.665245] wlan0: send auth to <MAC ID removed> (try 1/3)
[ 1316.766173] wlan0: send auth to <MAC ID removed> (try 2/3)
[ 1316.870062] wlan0: send auth to <MAC ID removed> (try 3/3)
[ 1316.973936] wlan0: authentication with <MAC ID removed> timed out
[ 1331.864836] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

    ======== Done ========

Thank you in advance.

btw, I'm studying Ubuntu because I found it is more fun than trying to cope with Windows. I could decide to switch my main platform to Ubuntu because of Ask Ubuntu community. Thank you all Ubuntu geeks.

  • I 've noticed this when I use WPA to connect to the router. Try using WPA2 - it works fine for me now. – apanagio Dec 28 '16 at 16:25
8

I suggest you try a driver parameter. Please open a terminal and do:

sudo -i
echo "options rtl8723be fwlps=0"  >  /etc/modprobe.d/rtl8723be.conf
modprobe -r rtl8723be
modprobe rtl8723be
exit

It may take a reboot. Any improvement?

  • Thank you very much! It worked and now I have a stable connection! But seems its slower than it supposed to be(or compared to windows). – Yuu Jinnai Oct 30 '14 at 15:00
  • Well, seems that's because I disabled IPv6. I'm going to test that tomorrow. – Yuu Jinnai Oct 30 '14 at 15:26
  • 1
    It solved all the problems! Thank you very much for your help. Would you be so kind as to explain me what was the cause of the problem? I'm trying to figure out by myself but cannot find information. – Yuu Jinnai Oct 31 '14 at 3:14
  • 1
    @SalathielGenèse This suggestion is now almost three years old. I suggest that you start you own new question and let's start fresh. – chili555 Aug 16 '17 at 19:47
  • 1
    @SalathielGenèse If you ask a clear, concise question, tell us the details about your wireless device, lspci -nnk | grep 0280 -A3 and ask for help, you will probably not get downvoted and I promise an upvote. – chili555 Aug 22 '17 at 20:45
0

I added the following lines in /etc/modprobe.d/iwlwifi.conf:

options iwlwifi 11n_disable=1

options iwlwifi swcrypto=1

and the bug is gone!

  • 2
    You have a different wireless adapter. This answer is not relevant at all. – Pilot6 Jan 24 '16 at 20:07
  • I never posted what is my network adapter. Dont assume before hand. There May be more solutions to this problem. I did a "lshw -C network" command and my network adapter is "RTL8723BE PCIe Wireless Network Adapter". This is same as in the question Before commenting first "think". – Raj Jan 27 '16 at 5:15
  • 1
    But the commands you posted as an answer setup iwlwifi module, that is a driver for Intel wireless adapters. It does not affect Realtek adapters in any way. – Pilot6 Jan 27 '16 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.