3

I have just upgraded to 14.10. The upgrade worked very well except for the graphics driver. It's an ATI Radeon, and the default built-in driver was active. It worked but it didn't look right, so I installed the proprietary fglrx driver instead with the expectation that it would help. However...

When my computer now starts (with normal boot options), it does not open the login GUI but instead ends at tty1. I can log into this, but I can't get it to start the GUI.

Here's what I've checked and/or tried so far:

  • "quiet splash" is turned off in the grub config, and I don't see any remarkable messages, no errors.

  • when I enter "startx" from the command line, I don't get any (EE) error lines or any "fatal" messages. It does say:

    /usr/bin/X: symbol lookup error: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/extensions/libglx.so: undefined symbol: LoadExtension
    Xinit: giving up
    Xinit: unable to connect to X server: Connection refused
    Xinit: server error

  • fglrxinfo gives the error "Error: unable to open display (null)".

  • /var/log/Xorg.6.log has no (EE) errors, only a few unrelated (WW) warnings about "cyrillic does not exist" and such.

  • I tried removing the xorg.conf file; same result.

  • I tried putting the default xorg.conf in place; same result.
  • I tried commenting out the "driver" lines in xorg.conf; same result.

  • sudo apt-get update & upgrade is also done, there's nothing to update.

How can I get the GUI back? For starters, I'd be happy to have the default built-in drivers. At this stage, getting the actual ATI drivers would be a nice bonus -- I want to use those because "Redshift" adds a screen overlay that doesn't work with the default drivers.

Update:

I managed to remove the ATI drivers with "apt-get purge fglrx" as stated here. It gives me an unusual greeter, not the typical Ubuntu one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.