0

Yesterday, I had some updates that Ubuntu(14.04) suggested to install, and I didn't pay attention which programs where updated.
After the update the system needed to restart, but I just clicked Restart Later.
Now, when the pc starts, the screen has lower resolution than it had yesterday and after logging in, the left side bar doesn't appear on the screen.

I remember having problems updating the Nvidia drivers on previous system updates, but I didn't care much because the system was working, and those errors were shown after the update and not after system reboot.
My graphics card is a Nvidia GT540M.

--- EDIT: ---

I cannot open any graphical terminal (I think) after logging in (Ctrl + Alt + T doesn't do anything), nor do anything else. I get stacked with only the background image. I can only open a tty terminal, but then I cannot run graphcal commands like:

unity --reset

I think that the problem might come from nvidia so I wanted to uninstall it. If I run:

$modprobe -R nvidia

I get the nvidia-340 package-driver, but if I try to uninstall it, I get:

$sudo apt-get remove nvidia-340
Unable to locate package nvidia-340

--- EDIT 2: ---

Thank you for your help. I managed to uninstall the Nvidia drivers and my systems worked. But when I re-install any driver from the Nvidia my system goes to the same situation after rebooting. Neither solution helped in my situation.

(Sadly I do not have enough point to vote up the answers, that were helpful nevertheless).

0

About resolution first of all check if you use correct driver for you graphics card if yes, try this in terminal :

xrandr -s 1024x768( change to your resolution)

About bar if it is unity try this in terminal :

unity --reset

or

sudo apt-get install dconf-tools

dconf reset -f /org/compiz/

setsid unity

unity --reset-icons

It resets Unity .

  • My problem is that I cannot open a terminal (nor open anything else, I think) after logging in. I tried Ctrl + Alt + T but nothing opens. If I go to tty (Ctrl + Alt + F1) then I cannot do anything that involves windows and display (e.g. use the xrandr command you wrote). – Grey Oct 30 '14 at 9:48
  • Maybe could you try to create launcher on desktop by right click mouse , then fill "gnome-terminal" as the command and name. then click OK. And try to launch it. – Dambre Oct 30 '14 at 10:15
  • Right click has no effect. The only thing I can do is press either Cancel or Report problem in the five dialog boxes that are shown when I log into the system. – Grey Oct 30 '14 at 10:47
  • did you try ctrl+alt+f6 combination to login to other user? – Dambre Oct 30 '14 at 15:17
  • or you could try ctrl+alt+f1 , use your credentials, and then "sudo apt-get --purge remove nvidia-*" after removing drivers , instal them again by writing few commands: sudo add-apt-repository ppa:ubuntu-x-swat/x-updates, sudo apt-get update, sudo apt-get install nvidia-current nvidia-settings – Dambre Oct 30 '14 at 15:20
0

I've just had the same problem, and I think it was some kind of update yesterday (I think this is really strange).

So, after booting ubuntu, I went to tty (Ctrl + Alt + F1), and I installed the last nvidia driver I get (write "sudo apt-get install nvidia-" and then hit tab to see the versions available):

sudo apt-get install nvidia-331
sudo apt-get install nvidia-331-updates

I went back to screen using Ctrl + Alt + F7 (in my case it was F7), and reset computer. Until now is working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.