I am trying to setup Mozc or Anthy, as long with English alternative.

So far I have tried severals methods:

  • Complete purge/reinstall of the languages support that I need.

  • Complete purge/reinstall of ibus.

  • Replace of im-config by the im-switch.

  • After that, purge of im-switch and reinstall of ubuntu-desktop...

  • fcitx-mozc input method instead of ibus.

And many minor editing/tweaks like adding iBus to startup programs, .bashrc editing...

Now, I am able to change the language using (Crtl+Space) and it work perfectly when I test it inside the launcher (using super/windows key).

enter image description here

The same goes for Anthy and English alternative.

However, when I try to use it in anywhere else, the language icon became gray and I cannot get any Japanese character working.

keyboard indicator became gray

I know (and I am following some) that there are some bug related problems involving Japanese and language/text entry, but I am not sure if they apply to my case since I have it working in some places.

Also, I suppose that even if it is a bug, there may be at least some kind of work around (and I tried some available in Ubuntu - Launchpad with no success other than the mentioned above) since its unlikely that Japanese is no longer supported in Ubuntu.

Because of that, other than suggestions like copy/paste from the launcher, is there any procedure that you can recommend in order to fix this problem?

From the moment I would like to have it working at least for Firefox and for some text editor (vim or geany if possible).

By the way, from the responses presented in the similar questions in this site, I had tried almost all that appears to be correlated with my problem/Ubuntu version.

  • 1
    Why on earth did you do all those things? I would recommend that you study this docs page to start with. Oct 29, 2014 at 20:53
  • @Gunnar Hjalmarsson, I wish it was that simple, if it was I would have solved it a long ago. However, you probably be aware that there are some kind of problems with ibus for asian languages and simple installing the language and changing it using text entry settings as suggested by the doc you send don't work at all. Oct 31, 2014 at 13:02
  • I think it is that simple, and I'm not aware of any general "problems with ibus for Asian languages". Please see the answer I just posted. Oct 31, 2014 at 16:44
  • Btw, given that you seem to be using fcitx now, have you switched from IBus to fcitx in Language Support? Oct 31, 2014 at 16:51

2 Answers 2


I took these steps on a clean Ubuntu 14.04.1 install:

  • Installed Japanese via Language Support.
  • Installed ibus-mozc via Ubuntu Software Center.
  • Logged out and logged in again.
  • Added Japanese (Anthy) and Japanese (Mozc) from System Settings -> Text Entry.

After that I can open e.g. gedit, select Anthy or Mozc from the input source indicator, and type beautiful characters. :)

  • Maybe I have something broken in my current install. Before I tried that long list of procedures, I did almost the same steps that you suggest, with the only difference that I installed ibus-mozc (and maybe Japanese language) using terminal commands. Anyway, I unistalled/purged the Japanese language as well the ibus-mozc and tried to repeat the same process you suggested, but the results are the same. I can switch to Japanese language and it works perfectly while in launcher, but anywhere else, gedit included, the only thing I got are English characters, no matter which language I launch it. Nov 2, 2014 at 2:50
  • @DécioSoares: When in e.g. gedit, you may need to switch to the desired input method, either with the input method indicator or the shortcut (Super+Space by default). Nov 2, 2014 at 3:24
  • I know, the problem is that the switch (either by method indicator or by shortcut) produces any effect at all. The characters continues to be written in English. For example, after switching the input method (to anthy or mozc) I expected that when I typed "a" the kana あ appeared in the screen and this only happens while in launcher. However, no matter how many times I switch, only English characters appear in any program, except while in ubuntu launcher that both anthy and mozc works as it should. Nov 2, 2014 at 3:35
  • The two screenshots in my post shows what I am talking about, it's a bit small, but if you look at the first you will see that anthy (or mozc) is selected and it works fine in launcher, but in the second, even with anthy/mozc seleted, the icon becames gray and only english chars are written. Right now I am writting this edit with mozc selected and as you can see the chars inputed didn't change at least once. Nov 2, 2014 at 3:41
  • @DécioSoares: Is IBus selected in Language Support? Nov 2, 2014 at 5:54

I had the same problem in my Ubuntu 14.04. Neither anthy nor mozc worked anywhere except my launcher. I used the following steps and it resolved the problem:

  1. Open a terminal and run im-config, click ok and yes, then select ibus and click ok.
  2. Reinstall ibus and ibus-gtk:

    sudo apt-get --reinstall install ibus; sudo apt-get --reinstall install ibus-gtk
  3. Reboot the system.

Hope it helped. :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .