0

I have my Ubuntu installed on an SSD, and a secondary HDD called Earth that I've set to automatically mount at startup. The thing is, when it mounts, the folder is labelled "Earth1" instead of "Earth". There is still a folder in /media/username called "Earth" but when I attempt to open it, it gives the error:

This location could not be displayed. You do not have the permissions necessary to view the contents of 'Earth'.

So right now a whole bunch of programs are trying to access files in /media/username/Earth but returning errors.

This has been happening since I had a problem with Unity and had to reset some of my user settings. I'm currently logged in as admin, and I've checked the startup command and everything's fine there.


Update 2017-10-31 (for future reference)

I was using Startup Applications to mount Earth (BTW, Startup Applications runs at login, not at boot). Based on subin's answer, I switched to using the Disks utility, which saves its config to the /etc/fstab file (which tells the system to mount partitions at boot), and that worked fine. The fstab entry specified the mount point.

0

Correcting the line in /etc/fstab should help. If you have used the disk utility to setup the auto mount options, you should see a line which contains the mount point (here /media/username/Earth) Check if the line exists. If not, use the disk utility to set it up again. Looks like the directory /media/username/Earth exists and it is not specified as the mount point, so when the auto mounter sees the directory Earth already existing, it creates another directory Earth1 and mounts the partition there.

  • This fixed it, indirectly! I was using Startup Applications to mount the disk at boot. I switched to the disk utility and that fixed the issue. Thanks. – wjandrea Oct 31 '14 at 3:58
0

You may need to set user permissions by chowning the earth volume to your user name. This sounds complicated but is insanely easy & teaches you some CLI skills. (Not to be confused with chmod.)

  • After some time and experience, I ended up adding mount options to the fstab to the same effect: uid=1000,gid=1000,umask=022,users. I'm not sure if chown would have worked since Earth was an NTFS partition. – wjandrea Nov 9 '17 at 19:37
0

You can try changing it in /etc/fstab or making a folder in on the drive as root and then chowning it to your user. EDIT: I tried this a while ago and it worked perfectly after using fstab to mount it to the right place and chowning a folder to fix the user problems.

  • Does this answer add anything new? I mean, subin already mentioned editing fstab, and fleamour already mentioned chowning. – wjandrea Nov 9 '17 at 22:00
  • i meant to add that i had a similar problem and it fixed it for me – Dragon8oy Nov 9 '17 at 22:01
  • What fixed it for you? You wrote two different options. Also what did you change in fstab? – wjandrea Nov 9 '17 at 22:02
  • Changing it in fstab made it mount to the right place and chowning it fixed the user problem. What I mean is it took both. – Dragon8oy Nov 9 '17 at 22:04
  • Ah, I see. Please edit that into the answer. Thanks! – wjandrea Nov 9 '17 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.