8

I do yosemite upgrade on MacBook Pro (13 inchi, mid 2012 model). After upgrade it, I cannot boot into refit, no OS option available, just boot into Mac OSX yosemite directly.

  • I tried to reinstal refit, it didn't work.
  • I tried install refind with --esp argument as explain here, it also didn't work.
  • I install refind without any argument, just run install.sh, the message shows it can be installed successfully but nothing change.
  • I install refind with --alldrivers, the message shows it can be installed successfully but nothing change.
  • I do diskutil corestorage revert /dev/disk1 as explain here, it bring my Mac OSX yosemite into white screen only when booting. I repair it from recovery --> startup disk.

So, I would like to ask your help folks to solve my problem. Ubuntu on Mac is my main equipment to do a lot of my jobs, hence I need Ubuntu to show again on refit/refind boot on mac. Here is the content of my partition inspector I did from refit.

Current GPT partition table:
 #      Start LBA      End LBA  Type
 1             40       409639  EFI System (FAT)
 2         409640    331171351  Mac OS X HFS+
 3      331171352    332440887  Mac OS X Boot
 4      332440888    333710423  Mac OS X HFS+
 5      333711360    580364287  Unknown
 6      580364288    592750591  Linux Swap
 7      592750592   1465147391  Unknown

Current MBR partition table:
 # A    Start LBA      End LBA  Type
 1              1   1465149167  ee  EFI Protective

MBR contents:
Boot Code: GRUB

Partition at LBA 40:
Boot Code: None
File System: Unknown
Listed in GPT as partition 1, type EFI System (FAT)

Partition at LBA 409640:
Boot Code: None
File System: HFS Extended (HFS+)
Listed in GPT as partition 2, type Mac OS X HFS+

Partition at LBA 331171352:
Boot Code: None
File System: HFS Extended (HFS+)
Listed in GPT as partition 3, type Mac OS X Boot

Partition at LBA 332440888:
Boot Code: None
File System: HFS Extended (HFS+)
Listed in GPT as partition 4, type Mac OS X HFS+

Partition at LBA 333711360:
Boot Code: None
File System: ext4
Listed in GPT as partition 5, type Unknown

Partition at LBA 580364288:
Boot Code: None
File System: Unknown
Listed in GPT as partition 6, type Linux Swap

Partition at LBA 592750592:
Boot Code: None
File System: ext4
Listed in GPT as partition 7, type Unknown
  • What are the unknown partitions? Which one is you're recovery partition? – Daniel Oct 30 '14 at 14:50
  • My uknown partitions were ubuntu root directory (ext4, disk0s5) and another ext partition to save my data (disk0s7). Recovery partition should be disk0s4 and disk0s5 (both are hfs). – bagustris Oct 31 '14 at 3:40
7

did you "reinstalled" refit manually?

If you didn't, try running this on the OSX Terminal

cd /efi/refit   
./enable.sh

When prompted for password, use the one Yosemite asks you while trying to install new software.

After that, you should see the boot menu after you restart. When you choose to load Ubuntu from the boot menu, you may be greeted by the "grub rescue terminal" instead of a normal boot, let me know.

Hope this helps.

By the way, you can also press the option key ("alt") just after you hit the power button, and there you'll see some options, including refit. This has the drawback that it must be done on every boot, hence the preference for the terminal solution.

  • 1
    What you mean by install "manually"? I installed refit dmg file as usual. I also did ./enable.sh in /efi/refit, but nothing appears after reboot. when I press alt(option) or meta-R, EFI boot was shown, but it freeze/hang after all. – bagustris Oct 29 '14 at 11:03
  • I did this and it seemed to work, but then when booting up into ubuntu from refit I get a message on a black terminal to the effect of "No bootable device. Insert device and press any key." – nnyby Aug 19 '15 at 17:48
  • I did this, however refit was not present in the list of options. Only Macintosh HD was available. – CGriffin Sep 6 '17 at 18:53
3

I had the same problem with a Late 2013 Macbook pro. The refind worked for me with the command ./install.sh --esp --alldrivers, although my first impression was that I had failed. I just had to wait ~1 minute for the refind menu to popup during the boot.

To avoid this long wait at boot, you can make the following adjustments to your refind install.

From OS X:

  1. Mount your esp partition. mkdir /Volumes/EFI && sudo mount -t msdos /dev/disk0s1 /Volume/EFI
  2. Rename the refind folder BOOT. eg. /Volumes/EFI/EFI/refind becomes /Volumes/EFI/EFI/BOOT
  3. Rename the refind_x64.efi file to bootx64.efi. eg. /Volumes/EFI/EFI/refind/refind_x64.efi becomes /Volumes/EFI/EFI/BOOT/bootx64.efi

Umount and reboot. Enjoy! :)

  • ./install.sh --eps on refind is not work for me because I can"t mount my eps partition. My eps partition was disk0s1, when I tried mount -t msdos /dev/desk0s1 /Volumes/eps it said: mount_msdos: Unsupported sector size (0). Any idea to solve this problem ? need your help, folks. – bagustris Oct 29 '14 at 11:16
  • Do it from your OS X install. – amanthethy Nov 3 '14 at 18:03
  • Also, its --esp and not --eps. Editing to reflect this fact. – amanthethy Nov 3 '14 at 18:08
2

Booting your Mac via rEFIt please try this command

after installation of rEFit please open the terminal and run this command .

cd /efi/refit
./enable.sh

and reboot !

should be worked

0

Just finished a successful Mac/Yosemite Ubuntu dual boot update. Basically the guidance of http://www.rodsbooks.com/refind/yosemite.html is fine.

But note that from the GRUB choice available under ReFIT or its REFIND successor, one could more laboriously boot with:

grub> ls

to display the partitions. For the partitions above, retention of the Linux file system would be reported by (gpt4 is really the fifth partition):

grub> ls (hd0,gpt4)/

and the standard Ubuntu grub menu will be called up by

grub> configfile (hd0,gpt4)/boot/grub/grub.cfg

The further comments herein provide a new option within the REFIND choices.

Note within the partition info above:

Partition at LBA 331171352:
Boot Code: None
File System: HFS Extended (HFS+)
Listed in GPT as partition 3, type Mac OS X Boot

Partition at LBA 332440888:
Boot Code: None
File System: HFS Extended (HFS+)
Listed in GPT as partition 4, type Mac OS X HFS+ 

The "partition 3" contains the new Recovery Partition version 10.10, with LVM Boot capability as mentioned in yosemite.html.
The "partition 4" is the old Recovery Partition version 10.9 which is no longer necessary! If can be reformatted to HFS+, and REFIND can be installed therein.

Hold down the "option" key upon a reboot and it will report icons for 10.9 and 10.10, Previously under Maverick, a Windows icon was actually for the Ubuntu partition, and I could thus boot Ubuntu. But with the Yosemite update, this is no longer effective.

For reasons obscure the standard "Disk Utiliy" did not report separately report the two Recovery partitions. But my memory may not be sound on this point. If both Recovery partitions are displayed by Disk Utility, the gdisk delete procedure mentioned below can be skipped. Just use the Disk Utility ERASE option to reformat partition 4, to HFS+ , with name "efi" .

As a preliminary install http://www.rodsbooks.com/gdisk/ and of course the most recent REFIND version. Use gdisk to CAREFULLY delete (in this case) Partition 4 (the Mac OS X HFS+) being careful not to take out its Recovery 10.10 replacement (Mac OS X Boot). Their should be a normal MAC boot subsequently, starting within the retained partition 3, and under LVM control, bringing up the main "partition 2" MAC installation.

Now use the standard "Disk Utility" to make a HFS+ partition in the free space, which could be named "efi". It will show as /Volumes/efi/ and be used for the ReFind installation.

Within my unzipped folder Downloads/refind-bin-0.8.3/, there was run:

$ sudo ./install.sh  --alldrivers --ownhfs  /dev/disk0s4

--- reporting ----
Installing rEFInd on OS X....
UnmountEsp = 0
Installing rEFInd to the partition mounted at /Volumes/efi
Copied rEFInd binary files
Copying sample configuration file as refind.conf; edit this file to configure
rEFInd.
WARNING: If you have an Advanced Format disk, *DO NOT* attempt to check the
bless status with 'bless --info', since this is known to cause disk corruption
on some systems!!
Installation has completed successfully.
--------

Editing the refind.conf.sample provided, the yosemite.html instruction was followed to change:

dont_scan_volumes "Recovery HD"

INTO

dont_scan_volumes foo,bar

While a delay way not be necessary on your System, there was also done a change:

# scan_delay 5

INTO

scan_delay 1

This enabled appearance of the MAC boot icon later, without having to ESC for a rescan of the partitions. The saved file was called refind.conf.edit My text editor is "gedit" for MAC, but any text editor should do, that saves to plain text.

Finally the edit was copied (on one line) as below, thus overwriting the original established during the install:

$ sudo cp refind.conf.edit /Volumes/efi/System/Library/CoreServices/refind.conf

Check that your edits are indeed within with (say):

$ less /Volumes/efi/System/Library/CoreServices/refind.conf

Upon reboot, the REFIND menu came up with Ubuntu kernel boot choices. There are a couple of non-functional icon choices, which I have not yet eliminated from the display. But the Ubuntu boots are fine.

PLEASE do read all the documentation mentioned above CAREFULLY. My terse comments herein are NOT a sufficient guide. But to summarise:

  1. if REFIT has been retained, a Ubuntu boot could be likely be done with:

    grub> configfile (hd0,gpt4)/boot/grub/grub.cfg
    
  2. To get a lazier bootup, work through the REFIND installation steps, and learn from the process.

-2

If Ubuntu is really important to you, I would reccomend installing grub. I believe you could install grub with boot-repair. More about boot-repair here: https://help.ubuntu.com/community/Boot-Repair.

  • Of course I use grub, but grub is installed after Refit/Refind because it use EPS (Efi Partition System). In efi model, you cannot install grub directly. – bagustris Nov 1 '14 at 23:39
  • @bagustrus that's odd I had a 2010 mac book pro and I was able to install grub just fine. But since yours is a little newer I guess it might be different. But have you tried installing grub directly? It might be worth a shot. Nothing to lose at this point I guess. – rajlego Nov 2 '14 at 14:19
  • If you install grub directly to /sdx, remember you'll have to hold option anytime you want to boot into OS X. – amanthethy Nov 3 '14 at 22:31
  • People who are down voting this comment , please explain why. – rajlego Nov 3 '14 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.