11

I recently installed Ubuntu 14.04. I have an NVIDIA GeForce GT 540M (1GB) graphics card, and I noticed the open source Nouveau display driver was returning error code -16 on suspend, causing the computer to immediately rewake. So I switched over to the proprietary, tested NVIDIA v331.38 driver.

This fixed the suspend problem, but now the display will occassionally freeze and stop accepting input. The computer itself doesn't freeze -- audio keeps playing and touchpad input still goes through.

For some reason, when I switch over to the terminal using Ctrl+Alt+F1 and then switch back with Ctrl+Alt+F7, the display unfreezes and everything's fine until the next freeze.

It seems the freezing happens more often if I'm using my touchpad more actively. It's only brought on by a touchpad input as well. It won't freeze on its own.

3

6 Answers 6

1

By any chance, are you using a touch pad? If so, changing the touch pad to work as a normal usb mouse will correct issues with a 'unresponsive screen.' Unfortunately, you will not be allowed to use the tap to click feature or scroll using the pad.

1
  • I do have a touchpad, but if it will disable scrolling, this is not a workable solution for me.
    – Mack
    Oct 28, 2014 at 22:50
1

This is a known bug. Fortunately, there is a fix now (but you'll need to compile packages yourself). See https://bugs.launchpad.net/ubuntu/+source/nvidia-prime/+bug/1220426.

0

I had a very similar issue with my 14.04 install. It would freeze for seemingly no particular reason. I blamed various pieces of software before realising it was the graphics drivers.

This post I found really useful in starting me on my journey to actually having working nvidia drivers.

How do I install the Nvidia driver for a GeForce GT 630

0

I resolved the problem by switching over to the legacy driver - version 304.117 from nvidia-304-updates.

0

the following three BiOS settings ( 3 CMOS settings ) fixed it for my ASUS M2N MX SE PLUS motherboard with AMD Athlon® 64-bit 2-core CPU 4200+ ( and with NViDiA GeForce 6150SE graphics chip:)


❶ CPU clock = 200 MHz "manual" ( Not "Auto"; not "Limit" )

❷ 4 GB RAM clock = 200 MHz "manual" ( Not "Auto"; not "Limit" )

❸ PCi express clock = 100 MHz "manual" ( Not "Auto"; not "Limit" )


with above setting, AMD 64-bit 2-core CPU runs at 2.21 GHz speed ( else if the BiOS CMOS setting is

either "Auto"

or "Limit = 250 MHz" or "Limit = 275 MHz"

then it may be randomly varying the clock speeds during run-time i guess ( also known as Spread-Spectrum-Clocking...

0

Check the additional drivers on control panel > Software & Updates. Choose the proprietary driver.

After, enter on terminal (Ctrl + Alt + T) and perform:

sudo depmod nouveau
sudo rmmod nouveau
sudo update-initramfs

Reboot the system.

1
  • I am already using the propriety driver, and the nouveau module is not loaded. Additionally, I believe the depmod command requires an absolute path to the module to generate dependencies for. Altogether this answer doesn't really do anything for me.
    – Mack
    Oct 28, 2014 at 23:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.