1

I've tried all the fixes and ran out of Google.

At first I had to type "sudo modprobe -r ideapad-laptop" into the Terminal at startup for the wifi to work. Now it works after I did a more permanent Terminal fix I found here. But it stops working after around ten minutes.

Help! Isn't there a driver I can install or anything? This is the first time I've ever had problems with Ubuntu and I don't wanna install Win 8 again.

  • can you provide output of lsusb and lspci? – thatmaheshrs Oct 28 '14 at 15:15
  • Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 005: ID 0bda:b728 Realtek Semiconductor Corp. Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller Bus 001 Device 003: ID 5986:0652 Acer, Inc Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub – Liam Seeland Nov 16 '14 at 0:21
  • and lspci pastebin.com/gBHhEtkX – Liam Seeland Nov 16 '14 at 0:22
1

You can try what is described here: Lenovo g5030 not having any hardware switch for wifi or bluetooth after installing ubuntu 14.04

basically try to write this in terminal:

sudo rmmod ideapad_laptop

if it works, the for make it permanent try:

echo "blacklist ideapad_laptop" | sudo tee -a /etc/modprobe.d/blacklist-ideapad.conf

for me it worked flawlessly...

  • 1
    It says it's not loaded. Hmm. Thank you anyways (~: – Liam Seeland Nov 16 '14 at 0:22
  • 3
    If your answer is essentially a referral to another question, it would be better to flag this question as a duplicate of the other (with the [flag] button below this one). – David Foerster Dec 11 '15 at 11:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.