8

When I add a PPA via Software Sources it normally would show up in the Ubuntu Software Center shortly after. But lately it seems that any PPA I add either won't show up, or takes days to. Does anyone know what could be wrong?

5
  • DId you update the package database (apt-get update)? Do they show up in Synaptic?
    – RobinJ
    Jul 23, 2011 at 19:33
  • @RobinJ I think the package sources list is reloaded after adding a PPA: video: Adding a PPA to Ubuntu using the Software Centre
    – Lekensteyn
    Jul 23, 2011 at 19:36
  • I've done apt-get update, and reloaded the cache using Software Sources. I've just found out that the PPA will only appear if I first install something from it using the terminal. This is strange.
    – Alan
    Jul 23, 2011 at 19:44
  • @Alan: You can answer your question and mark it as answered. Don't worry, it is as compliant with AskUbuntu community policies Aug 10, 2011 at 8:24
  • Hi Manish. I was hesitant to mark it as solved at first, I'm not sure if the question is really answered or not. Never the less, I will mark it as solved, and report this as a bug. Thanks!
    – Alan
    Aug 11, 2011 at 0:08

2 Answers 2

2

If this is the same bug that's been around for as long as I can remember then you need to run sudo update-apt-xapian-index -f to get the Software Center to update your added repo's. On further research, there are bug reports for this issue not showing added repo's and also for continuing to display repo's that have been removed. Either way, running this code will work for both. As of 13.04 this issue still persists.

1
  • saw it on 14.04
    – xealits
    Aug 27, 2015 at 16:56
1

This issue can be partially resolved by installing something from the PPA via terminal first. Only then will you see the PPA appear in the Software Center.

1
  • I install all PPA's via terminal. It doesn't make a difference on my system. But the answer I provided above does.
    – jwdinkc
    Jun 27, 2013 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.