I have been trying to install oracle 12 c on Ubuntu 14.10 but facing the below mentioned error.Could some one please check this and advise me how to fix this error?

Checking Temp space: must be greater than 500 MB.   Actual 429214 MB    Passed
Checking swap space: must be greater than 150 MB.   Actual 4041 MB    Passed
Checking monitor: must be configured to display at least 256 colors
    >>> Could not execute auto check for display colors using command /usr/bin/xdpyinfo. Check if the DISPLAY variable is set.    Failed <<<<

Some requirement checks failed. You must fulfill these requirements before

continuing with the installation,

Continue? (y/n) [n] Y

>>> Ignoring required pre-requisite failures. Continuing...
Preparing to launch Oracle Universal Installer from /tmp/OraInstall2014-10-27_11-15-08PM. Please wait ...oracle@v3nky-HP-Pavilion-dv6-Notebook-PC:~$ No protocol specified
Exception in thread "main" java.lang.NoClassDefFoundError: Could not initialize class sun.awt.X11.XToolkit
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:171)
    at java.awt.Toolkit$2.run(Toolkit.java:834)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:826)
    at com.jgoodies.looks.LookUtils.isLowResolution(LookUtils.java:484)
    at com.jgoodies.looks.LookUtils.<clinit>(LookUtils.java:249)
    at com.jgoodies.looks.plastic.PlasticLookAndFeel.<clinit>(PlasticLookAndFeel.java:135)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:249)
    at javax.swing.SwingUtilities.loadSystemClass(SwingUtilities.java:1852)
    at javax.swing.UIManager.setLookAndFeel(UIManager.java:557)
    at oracle.install.commons.util.Application.startup(Application.java:792)
    at oracle.install.commons.flow.FlowApplication.startup(FlowApplication.java:181)
    at oracle.install.commons.flow.FlowApplication.startup(FlowApplication.java:198)
    at oracle.install.commons.base.driver.common.Installer.startup(Installer.java:355)
    at oracle.install.ivw.db.driver.DBInstaller.startup(DBInstaller.java:130)
    at oracle.install.ivw.db.driver.DBInstaller.main(DBInstaller.java:161)
  • First observation: The installer seems to try to open a GUI and can't find a DISPLAY. Are you running this on a headless server? Is there a option to tell the installer to install without a display? If you connect with ssh you could add the option -X and use your local display. Does that help?
    – MadMike
    Oct 28, 2014 at 6:47
  • Thanks for an update Mike..i am not installing it on server..i am doing it on my home laptop.. Oct 28, 2014 at 12:24
  • Could some one please help me on the issue? Oct 31, 2014 at 20:34
  • I'm not sure if I can help you. Still, adding more information might help others to find a solution. Please click edit below your question: Do you follow a tutorial? On which step did this error happen? Was there anything else didn't quite work?
    – MadMike
    Oct 31, 2014 at 20:40

3 Answers 3


Check if some JDK is installed in your system:

$ java -version

Installing JDK 7 solved my problem:

$ sudo apt-get install openjdk-7-jre-headless

If the problem persists, log as root, then execute:

$ xhost +

Switch back to another user and run installation again.


I had this as well. As root, I executed xhost + first and then it worked.


Solution, copy the file:

cp /root/.Xauthority /home/grid/.Xauthority

Insure that the user can read & write to the file by:

chmod 600 /home/grid/.Xauthority
chown grid /home/grid/.Xauthority

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.