I want to get keymaps of the keys using acpi_listen for some keyboard layout issues. But when i run acpi_listen and press any alphabetical key, it will only display that letter(Suppose I press a it will display 'a' only, nothing else). ctrl, shift and other supporting keys are not even detected. I am using Ubuntu 14.04, hp-dv6 pavillion


According to Linux man page, acpid is the system-wide ACPI event catcher. acpi_listen is a simple shell-friendly tool which connects to acpid and listens for events. When an event occurs, acpi_listen will print it on stdout.

As far as i understand, the keys ctrl, shift are not event creating keys. fn keys coupled with up or down (for toggling brightness/volume for example) might give desired outputs.


acpi_listen is for observing cmds to the ACPI runtime, So if you where to say increase or decrease the brightness on your laptop you would see this.

video/brightnessdown BRTDN 00000087 00000000
video/brightnessup BRTUP 00000086 00000000

I'm not really sure which tool you should use for listening to general key presses, but I know it's not acpi_listen.

  • 1
    I am not even getting output like this for brightness and volume buttons. – hunch Oct 27 '14 at 21:12
  • Is acpid running? Sometimes (rarely) those functions don't go through ACPI and instead go through some board support module right into whatever the precussor to ACPI was (I can't remember, probably trying to forget). If acipd is running you should definitely see something there if you leave acpi_listen on while you press the suspend button and then resume. But ACPI isn't your problem, it's keymapping, so just for forget about it for now. It appears xev may help you. – ppetraki Oct 27 '14 at 21:17
  • My Fn key is not working. Few days back it was working properly(related options to Fn key too). At that time I checked acpi_listen, it was showing results like the ones you mentioned in your answer. Now there is nothing, that is what bothering me. Is there a chance that some application or tool may cause this problem? – hunch Oct 27 '14 at 21:27
  • Do you have an external keyboard you can plugin that has a function key? I have a cheesy logitech k830 that does. It could be that the key just failed. Also, if you could boot into Windows and see if still worked that would be a fine data point. Which would point to a recent update which broke your Fn key. – ppetraki Oct 28 '14 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.