0

I have a Laptop running Ubuntu. The external Hard Drive is attached to the netgear router. Both are wire connected. The external Hard Drive shows under the network section in files. but when I try to get plex to find it the external Hard Drive doesn't show up.

I tried the instructions for Mounting NTFS Drives on Linux https://support.plex.tv/hc/en-us/articles/200288606-Mounting-NTFS-Drives-on-Linux this gives an error that the devise is in use or already mounted. So I unmounted it and tried again and received the same error.

Perhaps using this process I am reading the NTFS drive of my laptop? I cannot tell.

I tried adding this entry to /etc/fstab

//192.168.1.1/USB_Storage/mybook/ /media/public ntfs-3g permissions,auto 0 0 

got an error:

ntfs-3g: Failed to access volume '//192.168.1.1/USB_Storage/mybook/': No such file or directory

I don't have much experience with Ubuntu. Any help would be greatly appreciated. Chris

  • 1
    ntfs-3g is probably a wrong file system for a network share, try cifs instead. – mikewhatever Oct 27 '14 at 21:03
  • As @mikewhatever said. Don't try to mount it wirh ntfs, even though your hard disk is formatted like this. Drives connected over network need to be mount with a networking protocol like smb. In that case you need to mount it with the cifs driver. – MadMike Oct 28 '14 at 6:58
0

You will need this package:

sudo apt-get install cifs-utils 

Create a mount-point:

sudo mkdir /media/my_supercool_hdd

Add this entry to your /etc/fstab :

//192.168.178.100/my_shared_folder /media/my_supercool_hdd cifs auto  0 0

The entry above means:

//<Server>/<Share> <Mountpoint> cifs <mounting-options>  0  0

You can use auto as option to mount your share while booting or noauto to prepare it for later.

If your share is password protected your entry would look like this:

//192.168.1.100/my_shared_folder /media/my_supercool_hdd cifs user=john,passwd=supersecretpassword auto 0 0
  • lbreuer, I used cifs as you and Mike suggested but I get a request for a password: Password for root@//192.168.1.1/My_Book: The external hard drive has no password, its open to all on the wired network. sounds like I am close, this is the entry I used – Chris 98275 Oct 28 '14 at 19:24
  • i used //192.168.1.1/My_Book /media/my_super_hdd cifs auto 0 0 tried to use the Netgear password but got error: mount error(112): Host is down Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) I know its not down, I can see it on the windows computer. – Chris 98275 Oct 28 '14 at 19:35
  • @Chris98275 if you have no password, you need the "guest" option. Recently, you also need the "sec=ntlm" option. Here is my etc/fstab line: //192.168.1.1/USB_Storage/ /data cifs guest,sec=ntlm 0 0 – Andreas Jun 22 '15 at 15:04
0

To ensure the drive is properly unmounted, can you find the output of the command!

lsof -p <mount_path_HD>

Also, once that is umounted,

Try to see if there is an entry in the disk list with!

sudo fdisk -l

Presuming the external disk as ``172.16.0.172:/mnt/netgear` , mount as follows!

Then try mounting!

sudo mount -t nfs /mnt/netgear /media

before mounting, make sure you have created a folder named media

Then make an entry in fstab as follows!

172.16.0.172:/mnt/netgear /media nfs defaults 1 2

HTH!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.