1

I just bought a new laptop which came with Ubuntu 12.04 LTS. I had read a little about Ubuntu in school and was excited to try it out, but I soon found that my previous knowledge was highly wanting. At first I had no problems, but when I tried installing an antivirus, I found that debian packages could not be opened/installed/used without some sort of graphical package management program like Synaptic or Gdebi. So I installed Synaptic first, which refused to recognize the file name of the antivirus file package, and then Gdebi, which found the file ok but said that "dependency not satisfied: libicu42". So I went ahead and installed that as well, but still it showed the same problem. After all this I decided to listen to the Update Manager and upgrade to 14.04, hoping that such problems as I was facing would be automatically resolved in the latest version. That's when my problems really started. As I said, I have never used Ubuntu before, so I don't know if this is a regular thing or not.The upgradation was in six steps, out of which, installing till the third step took 12 hours straight. Twelve Hours Straight. And then in the middle of "Installing Updates", specifically, "Preparing gnome calculator", it just froze. The dialog box turned gray, and it just stopped working. I left it like that for about 45 minutes, but it showed no change and the screen dulled. When I moved the pointer to activate the screen, it gave me a dialog box with those tiny rectangles instead of characters and the picture of a red start button. I closed it once but nothing changed so I decide to take a chance and the next time it appeared, I clicked on the recommended red coloured option button choice. It restarted the laptop, but then the black terminal-type screen appeared and started giving out a repeated message that terminated in "will now halt" and just shut everything down. Ever since then, whenever I push the power button, it shows the black Dell logo screen, the purple Ubuntu logo screen and then dulls down. Nothing happens unless I push the power button again, when the same error message screen appears. It is really frustrating since the laptop is brand new, and I can literally do nothing on it. I was just starting to get and like Ubuntu too. Please help this newbie out; I'm in desperate need!!

1

I've just been through a very similar problem.. I tried updating to ubuntu 14.04 and unfortunately the computer was left unplugged.. therefore installation did not complete and computer was stuck in a loop. I later tried to boot it from usb drive but just stuck in the ubuntu logo screen.. Eventually I ended up by restoring to factory . I did this by pressing shutting down and turning Power button + shift and leaving shift key pressed until I got the ubuntu factory restore menu.

Hope this helps!!.. I'll try updating to ubuntu 14.04 again later today. Good luck in all!

0

Double clicking your .deb package should have opened it with the Ubuntu Software Center and isntalled it. Although in general it is a better idea to only install software from the official repositories. Also, in many cases an anti-virus program on linux is not needed as discussed here.

Upgrading from one major release to another typically requires several gigabytes of updates. For example, when I upgraded from 14.04 to 14.10 I had to download 2.3GB. This could explain the 12 hours if you have a slow internet connection.

I've outlines several options below, but if I were you I would do a fresh install of 14.04 (I wouldn't recommend 14.10 yet as it just came out a few days ago).

Re-install 14.04

  1. Create a bootable USB drive or DVD on a computer running:
  2. Plug in the USB, start your computer, and boot from the Live Media.
  3. Choose "Try Ubuntu" when booting from the Live Media.
  4. Backup any files you care about (e.g. to an external hard drive).
  5. Install Ubuntu using the Live Media.

Reset to Factory defaults

If you run into driver problems such as the touchpad or audio not working, you might need Dell's version of Ubuntu. You probably have a recovery partition that can restore your laptop to factory defaults. Follow steps 1-3 above to perform a backup, shutdown your computer and remove the Live Media, then see if you can get to your recovery partition using this guide or look it up for your specific model on the dell support site.

Contact Dell Support

Alternatively, if it's a brand new laptop, you probably still have a warranty from Dell. You can always try Dell support.

See also

  • First off, thanks a lot for your time and support: I never imagined I would get help so quickly.I did try to open the .deb file by double clicking it and tried to open it in the Software Centre but was unsuccessful, which is why I went ahead with everything else. Also, I had heard about linux's famed security, but went for the antivirus just to be sure, my experience in which led me to thinking that if this particular debian is not working, then other required deb packages like in printer drives would also not open. I mean, isn't it important enough to figure out how to open .deb?? – Maeve Oct 28 '14 at 14:52
  • Anyway just now I'll try and install 14.04 from my Windows PC...Let's see how that turns out. Thanks!! – Maeve Oct 28 '14 at 14:55
  • Hey i tried installing it through usb but no luck. It says "no default or ui configuration directive found". When I tried Googling that, the usual solutions included properly formatting the usb, which I think is not the problem here cause the installer promised to correctly format the usb automatically. So, I'm at a loss again:( – Maeve Oct 30 '14 at 14:50
  • @Maeve That actually does sound like the USB might not have been created correctly. I've seen users here recommend this program for creating Live USBs if the one mentioned on ubuntu.com doesn't work. If you still have problems, could you provide the link from which you got your 14.04 iso? – TheSchwa Oct 30 '14 at 15:34
  • Here's the link for the iso : ubuntu.com/download/desktop – Maeve Oct 31 '14 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.