The most essential features of the Logitech T650 trackpad works right out of the box. However, I was unable to get ‘Natural scrolling’ to work.

After a bit of searching, I was led to this post by Franklin Strube on configuring the T650. In the post, Franklin suggests using xinput to reconfigure the trackpad.

To invert the scroll axis, I reordered the 4, 5, 6, and 7 buttons to 5, 4, 7 and 6 by entering the following into the terminal.

xinput set-button-map "Logitech Unifying Device. Wireless PID:4101" 1 2 3 5 4 7 6 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24

This resulted in natural scrolling to work immediately.

Unfortunately, this configuration doesn’t appear to be saved. On rebooting, the scroll axis goes back to the the original settings.

Any idea how I can save the modified configuration?


I suggest automatically running Your command on each system startup:

  1. Access startup applications preferences - Where did the startup-applications-preferences program go? (may be already present at Unity-Dash).

  2. Then add an entry containing Your command.

  3. Since that the configuration should be adjusted on future bootups.

You can also add the command to Your Unity launcher at Ubuntu Tweak (should be foundable at Unity-Dash), I have several commands stored in Terminal icon, pretty useful.

Still I'm too curios how to make the xinput config constant and why it is not remembered by default.

  • 1
    Okay, I added a T650NaturalScrolling.sh file to the Startup Application Preferences and it survives the boot. Thank you. – rahi Oct 27 '14 at 2:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.