First of all sorry for my english :)

I'm using VirtualBox 4.3.18 (downloaded from oracle's site)
I'm running ubuntu 14.04 as host and windows 7 64bit as guest.
When i plug the usb hard disk the host recognizes it, but if i start the guest and i open the devices menu i can see the entry for the hd, but it's greyed out and appears as not available.

1. i've installed both extension pack and guest additions
2. in the machine settings i've checked: Enable USB controller and Enable USB 2.0 (EHCI) cntroller
3. i've added the user to the vboxusers group with the command sudo gpasswd -a nomeutente vboxusers
4. i've tryed to plug the hd both before and after starting the guest without results
5. i.ve tryed to "safely remove" the drive and also to unmount it with the command sudo umount /media/user/drivename, but it still results not available.
6. i've tryed to create a USB Device Filter for the hd from the machine settings with the "plus" button, but no results, even retrying points 4 and 5

I have no more ideas, what can I try?
Thanks for any suggestion.

  • Did you also reboot the guest after you made your settings? – Takkat Oct 26 '14 at 19:59
  • @Takkat thanks for the tip, but I rebooted both the host and the guest several times without success – corros Oct 27 '14 at 8:40
  • Please check again with groups whether you are a member of vboxusers. Also, the USB-drive has to be formatted as Windows compatible (NTFS, FAT32) - if that was not the case you can only access it via a network share. Also see askubuntu.com/questions/25596/how-to-set-up-usb-for-virtualbox – Takkat Oct 27 '14 at 8:55
  • Oh - and the USB drive has to be mounted in Ubuntu first before it can be used from the VM (it will be automatically unmounted from the host while accessed from the guest). – Takkat Oct 27 '14 at 9:03
  • @Takkat thank you again, but this not solve. - I checked with group and id and appears in the list the group vboxusers - the file system of the hard disk is NTFS - I looked at the link but I had already done all the steps - . i've tryed to plug the hd both before and after starting the guest without results - the only change is that now all the usb devices are not available, not just the hard drive – corros Oct 28 '14 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.