I currently assume Ubuntu 14.04 64bit OS. I mostly use Gnome shell (GNOME Shell 3.10.4) which I installed (I didn't install the whole Gnome desktop package).

I recently noticed a problem in changing input languages. I have 2 languages installed and I have set the shortcuts from System Settings(gnome) > Keyboard > Shortcuts as shown in the screenshot below:

http://i.imgur.com/Gs5Z5SK.png

The problem is that when I first login with Gnome shell all the shortcuts work great but after a couple of minutes when I open an application (eg. libre office, chromium) the shortcut Ctrl+Shift does only change to the next source and then it doesn't change back.

No change in the panel are shown (my primary language is english, and my second french) it only shows "en" but I can type in french. I should also mention that the other two shortcuts are working perfect but there is no change in panel as well so I can't tell what language input is selected unless i type.

In Unity everything works except for the modifiers-only switch to next source which isn't shown in the Unity system settings so that's normal.

Is this a bug? Is there anyone else experiencing it?

Thanks in advance for your time.

  • I can't tell whether it's a bug, but I suspect that the problem may be due to the mix of Unity and GNOME stuff. In other words it might have worked better if you had installed Ubuntu GNOME. – Gunnar Hjalmarsson Oct 27 '14 at 1:12
  • You are probably right. I will proceed to a fresh install of Ubuntu Gnome in the near future and see if the problem persists. As for now i disabled the modifiers-only switch to source and it seems that it's working better. Although, the panel doesn't show the selected language sometimes. Thanks for your response. – user254028 Oct 27 '14 at 13:50
  • It's a bug. Old, long winding one. Irritating. bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… and bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/…. I ended redefining my keyboard and not using switching, but I understand that for some language pair this is not viable. – Rmano Nov 26 '14 at 19:27

I've had the same problem as you had except I installed the whole Gnome desktop package. To solve this problem I log of the Gnome Shell then log in the Unity and set (re set) hotkey to change keyboard layout in Unity. Check if it work there and then go back to the Gnome Shell. It works for me. My answer is probably irrelevant for you now but I hope it'll help someone else. Sorry for my poor English.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.