0

I just started Ubuntu 14.01 on my VM VirtualBox virtual machine. VM windows has resolution ~600x500. Ubuntu system started and it is showing in this small screen. When I had tried to open some work windows, I realised, that real Ubuntu resolution is much more than screen of VM Virtual Box.

How I can set system resolution so it will be equal to VM window or how to set VM window so it will be equal to Ubuntu system resoltion?

2 Answers 2

2

First I have the CD/DVD set to Host with no disc in the drive, then set Display memory to at least 4 MB to use 32bit/8*1024*768*(number of monitors) I used 16 MB to try and get two display screens up and running.

Next Start the machine and once it is up and running, click on Devices and 'Insert Guest Additions CD Image' or hit Host+D, where Host in my case is Right Control.

Next it will prompt you to do the install into your virtual machine. After it completes, then restart the virtual machine and it will auto-size to your maximum resolution.

enter image description here

First I have the CD/DVD set to Host with no disc in the drive, then set Display memory to at least 4 MB to use 32bit/8*1024*768*(number of monitors) I used 16 MB to try and get two display screens up and running.

enter image description here

Next Start the machine and once it is up and running, click on Devices and 'Insert Guest Additions CD Image' or hit Host+D which in my case is Right Control key plus the D key. Next it will prompt you to do the install into your virtual machine.

enter image description here

After it completes, then restart the virtual machine and it will auto-size to your maximum resolution.

1

You must install Virtualbox Additions:

Click on | Devices->Insert Guest Additions CD Image | or press CTRL+D

After you have done this, you can change Ubuntu's resolution by launching system settings from the launcher:

| All settings->Display |

6
  • Thank you for you answer. Firstly, I tried what you said and restarted my pc. Secondly, I did actions, suggested in this answer (well, guess, it is same as you suggested, but by console). After that I restarted computer and got same resolution. Also, I tried suggestions from this answer and I still get same problem – same resolution. There is still only 640x480 option in Settings -> Display and still vm window doesn't stretch to guest screen size. Oct 26, 2014 at 17:32
  • Are you using the newest version of Virtualbox?
    – Ulincsys
    Oct 26, 2014 at 17:39
  • I am not sure. Not newest ver of VitualBox can cause such problem? Reinstalling VB additions right now, but I am not sure it will help me Oct 26, 2014 at 17:41
  • Try switching between video modes. |rightCTRL+F| twice
    – Ulincsys
    Oct 26, 2014 at 17:55
  • You can also try pressing alt+ctrl+Enter in the guest window to maximize it Oct 26, 2014 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.