I upgraded my 14.04 to 14.10 via "sudo do-release-upgrade" without strange messages.

After rebooting and entering the password for the encrypted system partition in the graphical form, TTY7 keeps blank. I can use TTY1 to TTY6 without problems.

My machine is a Thinkpad T400 with Intel Chipset Graphics.

Update 1: Tried to reinstall the kernel (sudo apt-get install --reinstall linux-image-$(uname -r)), but get an error:

reinstallation of linux-image-3.13.0-37-generic is not possible, it cannot be downloaded

Update 2: Followed the instructions in (Statement) "Ubuntu 14.10 won't work because black screen" solution described here (sudo apt-get install --reinstall xserver-xorg-video-intel), but without success.

Update 3: By coincidence, some graphics appeared on screen (TTY7) after hitting the combination Super+SPACE, which is a shortcut for changing the keyboard layout. Seems like it should work, but doesn't?

Update 4: Tried the approach from Ubuntu 14.10 no GUI or term login (adding "init=/lib/systemd/systemd" to the boot parameters), but without success.

Update 5: Tried removing the package "xserver-xorg-video-nouveau", as suggested in http://ubuntuforums.org/showthread.php?t=2245436. No success... Also, that thread suggested downgrading "xserver-xorg-video-intel". Downloaded and compiled the trusty sources (https://launchpad.net/ubuntu/trusty/+source/xserver-xorg-video-intel/2:2.99.910-0ubuntu1.1/+files/xserver-xorg-video-intel_2.99.910.orig.tar.gz), but also no success.

Update 6: Sound is also broken.

  • try installing another greeter, for instance sudo apt-get install lightdm-kde-greeter, and change it in /etc/lightdm/lightdm.conf ( more info here wiki.ubuntu.com/LightDM). I've had a bug on Fedora with gdm - the login screen was basically distorted, but changed greeter - and everything works – Sergiy Kolodyazhnyy Oct 27 '14 at 7:28
  • Tried, unfortunately didn't help. – fret Oct 27 '14 at 8:43
  • Did actually help in the end, thanks :) – fret Oct 27 '14 at 15:30
  • In that case, I suppose I'll add this to the list of answers bellow, if no one is against it , of course – Sergiy Kolodyazhnyy Oct 27 '14 at 22:03
up vote 1 down vote accepted

tty7:

Inspired by the answer from Vembu, I reinstalled my default window manager gnome-shell (apt-get install --reinstall gnome-shell). Then, I rebooted and ran

gnome-shell --replace

on tty1. Output:

gdk_mir_display_open
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Window manager error: Unable to open X display

After that, tty7 showed my gnome-shell again. Mouse pointer was invisible, showed up after relogging in. Unfortunately, this was no permanent solution. The procedure had to be repeated on every boot.

After further investigation, I stumbled upon the following remark in the [release notes of 14.10][1]:

Note. If you were using the gnome3-team/gnome3-staging PPA, you should run

sudo ppa-purge ppa:gnome3-team/gnome3-staging  

before upgrading.

I purged the ppa, reinstalled gnome-shell, added the ppa and ran dist-upgrade. Finally, I set gdm as default display manager (thanks Xieerqi). It works again!

Try this. Once you are booted up to the blank desktop... press CTRL + ALT + F1.

apt-get install --reinstall ubuntu-desktop
apt-get install unity
apt-get purge nvidia* bumblebee*
apt-get install nvidia-prime

shutdown -r now

Hope this helps!

  • I have no NVidia graphic card, but I guess I'll give it a try. – fret Oct 27 '14 at 6:14
  • Inspired me to reinstall my default wm gnome-shell, though I have no nvidia graphics. Might have helped to bring back tty7, thanks. Unfortunately, no permanent solution. – fret Oct 27 '14 at 8:43

This is a copy of my original answer I've posted on this question

Occasionally, the default greeter (aka login screen ) won't work properly. I've encountered such issue with Fedora 20, where default gdm greeter would distort the login screen badly, and the persons on this post also said changing greeter (as suggested by myself) helped.

To change a greeter, access tty console (by pressing Ctrl+Alt +F*, where F* is any F1 - F6 key), login, and download a greeter that you would like to have. For instance,

sudo apt-get install lightdm-gtk-greeter

or

sudo apt-get install lightdm-kde-greeter

Personally , I keep both of these on my machine.

Next, you need to tell lightdm desktop manager which greeter to choose on boot. To do that, type

sudo nano /etc/lightdm/lightdm.conf

Nano is a command-line text editor, IMHO simplest to use. Most likely, this config file will be blank, so you would need to add the following lines:

[SeatDefaults] 
greeter-session=lightdm-gtk-greeter

where lightdm-gtk-greeter , would be the name of the greeter you installed. Bellow is the screen shot of my lightdm.conf file.

enter image description here

For more information on lightdm display manager configurations, you can read the following sources, as well as man page for lightdm (man lightdm):

Arch Wiki Lightdm

Ubuntu Help Lightdm

To me, it appears that gdm starts too early. The following consistently seems to help:

  • Switch to a console via combination Ctrl+Alt+F1
  • Login
  • Issue the command sudo service gdm restart
  • If necessary, switch back to the graphical user interface via combination Ctrl+Alt+F1

The list of users appears.

It's strange that this issue appeared only after some time on my machine, after installing/upgrading a few packages on a clean system. Is it something like a boot order dependency issue?

EDIT: Adding a "sleep" to the init script that starts gdm actually kind of resolved the issue for me. Add the command sleep 2 as first line of the script block in /etc/init/gdm.conf. This seems to support the dependency hypothesis -- but of course is relevant only if you run GDM and not LightDM. YMMV.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.