3

I have a Acer Aspire 5755 with Intel video graphic, on Ubuntu 14.04, the combination Fn+/(Right/left) arrows can increase/decrease the brightness screen. Works fine on unity and with a grub modification (boot flags acpi_osi=Linux and backlight=vendor) the hot key work on any desktop environment.

I make a direct upgrade to 14.10, and the hot key can not work, even with grub modification. But i can chance the screen brightness in System settings → Brightness and Lock.

ls /sys/class/backlight/
intel_backlight

Anyone have a solution?

  • I had the same problem on a Dell laptop that also uses intel_backlight, however for me the solution required getting rid of the boot flags. See if this answer helps. – TheSchwa Oct 27 '14 at 6:46
1

I make some tests removing the grub flags. It doesn't work, but when I reintroduce the flags

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor splash"

and run sudo update-grub the hot keys start to work again. Now I can control the screen brightness with key combination.

0

I read a fix somewhere about that for Ubuntu 14.04.

Open a terminal and create the following configuration file, if it does not exist:

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf

Now you need to edit this file. You can use any editor be it a terminal one or graphical.

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Add the following lines to this file:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"EndSection

Save it. Log out and log in back

If it doesn't work simply go to usr/share/X11/xorg.conf.d and delete the 20-intel.conf file.

0

Since I cannot add an upvote or a comment i'll just do a repeat of Rick's answer but now in a different laptop running ubuntu 14.04. Here's the set up

  Acer Aspire V5
  Ubuntu 14.04 (updated several times)
  Linux Kernel 3.13.0-52-generic
  Intel graphics card

All i had to do was to edit the default grub file in the configuration directory /etc and then update the grub a restart and everything was okay HOT KEYS are back (serious face)!. instructions

   Fire your terminal >> **CTRL + ALT + T**
   Enter the following command >> **sudo vim /etc/default/grub**
   (or any other text editor you like)
   then find the line **GRUB_CMDLINE_LINUX_DEFAULT=""** (if it's not there then create one below GRUB_TIMEOUT=""

   put the following boot flags to enable the hot keys >> **quiet acpi_backlight=vendor splash**

   so in the end you have the following >> **GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor splash"**

I beleive that this configuration will work for most Acer Computers that are running Ubuntu. Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.