0

I've been using Ubuntu 14.04.1 with Gnome-Shell for a few weeks now and I decided to toy around with pantheon using this guide.

I decided it wasn't for me and I removed pantheon via purge. I also cleared all repositories from /etc/apt/sources.list.d

After removing Pantheon I came across a few things that didn't work like they used to:

1: Windows/Super Key does not open the overlay anymore. I cannot set this back in key-bindings.

2: Desktop background/appearances no longer works. Right clicking the desktop and selecting 'change desktop background' simply opens the gnome-control-center, where the 'background/appearance' option does not exist. Similarly, there is a 'background' option in the overlay of all my installed applications, however, it does the same as the desktop right-click option.

3: Same as #2 but for backups.

4: Now for some reason, I cannot install the 'places indicator applet' from extensions.gnome.org.

Things I have tried:

Completely remove gnome-shell and all configs and re-installing.

Reverted GTK from 3.12 (needed for Pantheon) back to 3.10(ubuntu stock).

Setting XDG_CURRENT_DESKTOP=GNOME to ensure it wasn't assuming pantheon was the default desktop for some reason.

I have attached a screenshot showing the overlay with the 'background' and 'backups' options available (circled in red). In the bottom-right corner is a screenshot of what my gnome-control-center menu actually has for options. Notice that 'background' and 'backups' are missing.

enter image description here

Additionally, since I don't feel it deserves a separate question and it isn't the main point of my question here. Does anyone know how to get a bluetooth indicator applet in the panel at the top of the screen? Seriously, that'd be great.

  • Update, It looks like the entry is wrong for the overlay and that's why the program doesn't open. I can get backups to open if I type /usr/bin/deja-dup-preferences So there's nothing wrong with the program. However, I can't figure out where gnome looks to create it's applications list in the overlay. It's not /home/user/.gnome/apps or /home/.local/applications – lbaile200 Oct 28 '14 at 20:34
1
+150

The Application list for Gnomes Overlay is the same as for it's menu You can find the shortcuts in /usr/share/applications/

Just copy one file. Python3.3 for example and fit it to your needs. Save it with a new name and sudo rights and your application will be back.

-1

Just had to install blueman like this:

sudo apt-get install blueman

Got it solved, bluetooth icon is now back in the unity top bar.

  • I'm not using Unity. Additionally, this doesn't really help with the core issue where certain items do not appear in the control center and do not open their respective applications. – lbaile200 Oct 30 '14 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.