14

After upgrading to Ubuntu 14.10 I now have no audio in any video file I render. I've tried both Kdenlive and Openshot and get the same results. All other audio works. All other digital movie files work fine. It's just the one's I'm rendering that have this issue.

1
  • Hello. This sounds more like a bug report than a question. Please consider filing it, so that the issue may be fixed. Open a terminal and type ubuntu-bug openshot and then follow the instructions.
    – v010dya
    Commented Nov 9, 2014 at 12:05

3 Answers 3

14

You need newer versions of libmlt6 and libmlt++3 than what Ubuntu 14.10 shipped. 15.04 already has the newer packages.

You can work around the problem on your 14.10 system by simply grabbing the newer version from 15.04 and installing them:

cd $(mktemp -d)
wget https://launchpad.net/ubuntu/+archive/primary/+files/libmlt%2B%2B3_0.9.2%2Bgit20141027-1_amd64.deb
wget https://launchpad.net/ubuntu/+archive/primary/+files/libmlt6_0.9.2%2Bgit20141027-1_amd64.deb
sudo dpkg -Oi *deb
2
  • 3
    What will happen during the upgrade to 15.04? Will we return to the repo's versions or be stuck on these manually installed ones forever?
    – mlissner
    Commented Mar 31, 2015 at 21:58
  • 1
    Perhaps a better question is why is this still a problem in 14.10? Just fix it already and send out an upgrade.
    – deltaray
    Commented Apr 5, 2015 at 13:00
10

Ok I have found a solution to this problem, this is a bug in mlt which was updated with the upgrade to 14.10. It's not related to pulse-audio!

Anyway the solution it's just to install the latest debian version of the package which has a bugfix for this problem. So you have to install libmlt6 and libmlt++3 (version 0.9.2+git20141027-1 for both packages, which are dependent on each other). So you go here: http://packages.debian.org/sid/libmlt6 and here: http://packages.debian.org/sid/libmlt++3 and in both pages at the bottom there's the option to Download the package, you choose your architecture and download both packages. Then you have to put both packages in the same folder, open that folder in the terminal and type "sudo dpkg -i libmlt++3_0.9.2+git20141027-1_amd64.deb libmlt6_0.9.2+git20141027-1_amd64.deb" where the name of the two packages can change if you have a different architecture than amd64.

These are the links to the bug in debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=760773 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=761593

Now I will try to notify the ubuntu developers to backport the package to 14.10.

0

Thanks peoples. But I decided to downgrade instead. Which fixed the problem. I'll be sticking with LTS releases from now on.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .