1

Hello I own an MSI Wind u123

lspci output:
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller (rev 22)
lspci -nn | grep 0280
02:00.0 Network controller [0280]: Realtek Semiconductor Co. Ltd. RTL8187SE Wireless LAN Controller [10ec:8199] (rev 22)

I've used ndisgtk successfully to install the windows 7 x86 driver. realtek driver ndisgtk dialog But for some reason I can't find the device in ifconfig

eth0      Link encap:Ethernet  HWaddr 00:24:21:63:35:3c  
      inet addr:192.168.1.8  Bcast:192.168.1.255  Mask:255.255.255.0
      inet6 addr: fe80::224:21ff:fe63:353c/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:8849 errors:0 dropped:0 overruns:0 frame:0
      TX packets:8848 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:6142013 (6.1 MB)  TX bytes:1266897 (1.2 MB)
      Interrupt:40 Base address:0x4000 

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:3275 errors:0 dropped:0 overruns:0 frame:0
      TX packets:3275 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:423576 (423.5 KB)  TX bytes:423576 (423.5 KB)

The output of ifconfig -a is identical as above. What can I do to fix this? Am I using ndiswrapper correctly?

  • 1
    Please amend your question to show: lspci -nn | grep 0280. I suspect a native Linux driver covers your device. Ndiswrapper uses XP drivers, not 7 or 8 or otherwise. – chili555 Oct 25 '14 at 22:02
  • Could you try sudo ifconfig -a? – user.dz Oct 26 '14 at 10:08
  • I will attempt to use the XP drivers. – Harry Moreno Oct 28 '14 at 2:48
0

Go through these steps (it's ok if you've done some these before already, try them out anyway in this order):

In terminal:

  1. Install ndiswrapper packages: sudo apt-get install ndiswrapper-common ndiswrapper-utils*
  2. Install the driver with sudo ndiswrapper -i drivername.inf from the folder where you have your windows driver files (*.sys, *.inf)
  3. Install package sudo apt-get install ndiswrapper-dkms
  4. Check the driver installation with ndiswrapper -l, notice the driver name(s)
  5. Do sudo modprobe ndiswrapper
  6. Check your ìfconfig. If the connection is listed, see number 7. If the wireless connection is not listed, try: modprobe drivername where drivername is the driver name result from number 4. If there are two of the names, run for both. Check your ifconfig in between.
  7. If you got your connection listed, add ndiswrapper as a last line in your \etc\modules file (plus, as new lines, either of the two driver names from number 6 if needed). This way the driver will be loaded on system boot.

If you got your network listed, see your network manager if you can connect to it.

Hope this helps.

  • this worked! I made sure to install the driver from /RT8187SE/WinXP/net8187Se.inf. Output of ndiswrapper -l was net8187se : driver installed device (10EC:8199) present (alternative driver: r8187se). This command sudo modprobe r8187se finally fixed it. Then added r8187se to the end of /etc/modules. Now I can connect to wireless on reboot. Seems like the chip is limited to 2g, can't join 5g networks. WPA2 Personal works. Make sure the hardware is on fn + F11. – Harry Moreno Oct 28 '14 at 3:10
  • Actually this probably means that you didn't even need ndiswrapper after all, but you just did not have r8187se module loaded. ;) – Ahti Komu Dec 8 '14 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.