45

As my keyboard layout doesn't suit me, I run xmodmap on login. The script is named .profile and it runs OK, but it breaks the Unity interface.

I want to know where to put the xmodmap line so that it executes on my login and doesn't break anything.

I have already tried putting it in the .bash_login and .bash_profile files, without success (xmodmap doesn't set my keyboard).

What are my options?

  • 4
    How does it break the unity interface? – djeikyb Jul 23 '11 at 0:28
  • I would like to add that if your xmodmap execution time is too long, you should remove all entries that you did not modify by hand. Keeping only the changes in your input file will make xmodmap run much faster. – user1071575 Nov 29 '16 at 1:31
28

The correct place to put xmodmap ~/.Xmodmap (so that your changes are read at startup) is in ~/.xinitrc (see explanation below), although you could alternately place the xmodmap command as a startup item (/usr/bin/xmodmap /home/user/.Xmodmap). I can say that for 12.04 (and presumably 12.10) that these two alternatives definitely do work, as either way they are read after you log in with lightdm. (I changed Return to Right Shift, and the change only took effect after entering my password and logging in).

Please note: if you are on Xfce, it is noted on the official Xfce FAQ that you may have to create a startup item instead of using ~/.xinitrc, and that you might have to delay the execution so the xmodmap changes are not overwritten by setxkbmap. You can use a delay to achieve this in your startup entry:

/bin/bash -c "sleep 20; /usr/bin/xmodmap /home/$USER/.Xmodmap"

(For the startup entry it is necessary to specify absolute paths)

Each time setxkbmap is run to change keyboard layout, you will have to run xmodmap ~/.Xmodmap again in the terminal.

Creating ~/.xinitrc

Create a file in your home folder called .xinitrc with

touch .xinitrc

and place in it:

xmodmap ~/.Xmodmap

Your Xmodmap file should not have entries in the xmodmap -e " " style as that is used in the terminal for temporarily setting the values. It must have entries in this format:

keycode 65 = Tab
keycode 23 = Space

It is often confusing which of the various X files (such as .xprofile, .xinitrc, etc) are read at startup, but .xinitrc does seem to be still read under 12.04, whereas .Xmodmap or .xinputrc are not read by themselves.

  • 5
    Note that if you make your changes with xmodmap -e '..., you can retrieve the right format for xmodmap .Xmodmap with xmodmap -pke, which prints out the current mapping - though you'll want to filter this down to just the lines that apply to the change you made. – Barry Kelly Sep 26 '13 at 14:08
  • 1
    This did not worked for me. I've created .Xmodmap and .xinitrc | Then I placed xmodmap ~/.Xmodmap into .xinitrc And then inside .Xmodmad I have keycode 166 = Prior keycode 167 = Next – miguelmorales85 Aug 10 '16 at 16:53
  • it's .xinitrc doesn't seem to be getting launched automatically anymore in Ubuntu 17.10. You'll have to autolaunch it with this command: /bin/bash -c "sleep 15 && /home/USERNAME/.xinitrc" – thebunnyrules Dec 15 '17 at 16:13
8

I'm using ElementaryOS (with its GNOME based window manager) and found a solution through using xdg autostart scripts. Many window managers are using xdg so I assume this approach also will work in other environments. At least it should work with GNOME.

xdg run scripts in ~/.config/autostart upon login in a X session. To load xmodmap config upon login, add the following script to ~/.config/autostart/xmodmap.desktop:

[Desktop Entry]
Name[en_US]=Xmodmap
Comment[en_US]=xmodmap ~/.Xmodmap
Exec=/usr/bin/xmodmap .Xmodmap
Icon=application-default-icon
X-GNOME-Autostart-enabled=true
Type=Application

Then logout and login again, and your Xmodmap configuration should've been loaded.

If it's not working, try to run xmodmap in terminal to see if it's xmodmap that complains:

$ xmodmap ~/.Xmodmap

If you don't get any error, run the following command to debug:

$ sudo cat /var/log/syslog | grep -B 5 -A 5 xmodmap
  • On Linux Mint 17 (based on: Ubuntu 14.04.5) the auto-start approach worked perfectly for me after using a ~/.xinitrc file failed. As hxpax pointed out, Mint users (probably most/all Debian derived Linuxes) can use a GUI dialog to add auto-start entries by way of Main Menu --> Preferences --> Startup Applications. – mattst Mar 9 '18 at 20:32
  • 2
    Worked ubuntu 18.04 – TooTone Sep 22 '18 at 10:31
2

I don't have the unity interface in front of me just now, but try clicking the Applications button on the launcher, then type startup. There should be an app called Startup Applications (or some such). Click it and add your xmodmap command (eg xmodmap /home/thiago/.Xmodmap).

  • I tried that a while ago but it didn't work out for me. I'm on windows right now but I'll try again later and I report here if it works. thx – Thiago Moraes Jul 24 '11 at 4:05
  • 2
    @Thiago Moraes Does this basic command work (if not, post the error)? xmodmap .Xmodmap – djeikyb Jul 28 '11 at 2:18
  • +1 this does work. To be more explicit I used the full path for .Xmodmap – pwned Nov 8 '13 at 5:52
  • 3
    this does not work. I am using 16.04 – miguelmorales85 Aug 10 '16 at 18:04
  • @miguelmorales85 does the basic command work in your terminal? did you try using an absolute path? – djeikyb Aug 10 '16 at 18:10
2

On Mint 17/18, I can achieve that bu put my scripts into the Startup Application, with 1 second delay.

As Mint 18 is derived from Ubuntu 1604, I think you can do the same, or install Startup Application managing panel first if it is not there.

Hope it helps.

0

I wasn't having much joy with any of the suggestions above (the .bashrc option wasn't really viable as it runs xmodmap on every new terminal)

I touched a script called xmodstartup.sh in my home folder

  #!/bin/bash           
  sleep 1;               
  echo "running xmodmap" 
  xmodmap ~/.Xmodmap     

with it saved, I then did sudo chmod +x xmodstartup.sh

then I simply added the executable file to gnome's "startup application preferences" window. bish bosh, English layout y Español on altgr :)

-1

Putting xmodmap changes in ~/.bashrc or /etc/bash.bashrc doesn't break anything.

Only downside is that one has to open a terminal after each boot to get it activated.

  • 3
    I'm already doing that, but the problem is that at every terminal I open, this command gets executed. It's only a moment but it's a little annoying and I would prefer a real solution. thx anyway – Thiago Moraes Jul 24 '11 at 4:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.