I stupidly deleted my home folder in Natty. It's still in the trash but I cant get there to undo. Any help will be greatly appreciated. Searching I couldn't find any solutions because I don't think anybody else did that yet. I can only use the command line at this stage, and I'm noob at that.

  • 1
    err.. it might actually be gone. You see, trash is stored in /home/<yourname>/.trash. If you're home directory is gone, the trash went with it. How did you delete it? EDIT: apparently .trash is out dated, 1 sec – user606723 Jul 22 '11 at 17:57
  • 2
    1 method I think that will work: use a live CD. Then you can use this to go to command line and move the files back from trash to your home. – Rinzwind Jul 22 '11 at 18:29
  • Add result of command ls /home .Maybe extundelete will help, extundelete.sourceforge.net. Just dont use that disc if you want your files restored. – Denwerko Jul 22 '11 at 20:03
  • thanx, will try try all suggestions just now, what happened is that I saw a file in my home dir called windows, opening it I saw a complete copy of my home dir.It was an ordinary file between my other files not hidden not ./ so I thought this is strange an I deleted It, and that is where my woes began, – Oortjies Jul 23 '11 at 7:49
  • Logging in I get this:-1st screen:- could not update ICEauthority File/home/user//.ICEauthority. 2nd screen:- There is a problem with the configuration server (usr/lib/libconf2-4/gconfig-sanity-check-2exited with status 256) 3rd screen _:- nautilus could not create the following required folders:/home/user/desctop/home/user/nautilus, Before running nautilus, please create these folders, or set permissions such that nautilus can create them. Some how I got a file list and saw my home dir is still there can remember how but I think It was with "ls" command. Hope this help you people a bit more. – Oortjies Jul 23 '11 at 7:50

Did you try the bootable CD? Rinzwind is correct. One way of doing this is by using a live CD. Boot the OS, mount the disk, and navigate via Nautilaus or a terminal to /media//user/.local/share/Trash Locate your data and move it back.


I got the same three problems

1st screen: could not update ICEauthority File/home/user//.ICEauthority.

It's possible that you were using a graphical application running as root that has updated your ICE Authority file with root permissions.

Try the following in a terminal session:

sudo chown $USER:$USER .ICEauthority

sudo chmod 0644 .ICEauthority

I tried this I was able to get out of this issue.

2nd screen: There is a problem with the configuration server (usr/lib/libconf2-4/gconfig-sanity-check-2exited with status 256) nautilus could not create the following required folders:/home/user/desctop/home/user/nautilus

Try executing this in terminal:

sudo chmod 1777 /tmp

I hope this may solve the issue. I haven't tried this.


It does not need to use Live CD, simply do a cp command or nautilus /path/to/trash and do copy with the GUI.

  • 2
    This answer doesn't seem helpful. Explaining what is the exact path to trash would be important. – viyyer Feb 5 '12 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.