3

I can't use my PC anymore after upgrading from 14.04 to 14.10. The download and upgrade process was good but now when I turn the PC on, I get a black screen with error:

system program problem detected

And two options: Cancel and Report problem.

I can only use the mouse but the desktop is black and there are no icons. I can't activate Terminal. I read various posts on the web and followed different guides, but haven't solved the problem.

I can't even install a new version of Ubuntu starting from a bootable USB. When the system starts instead of booting the live version of Ubuntu, I get the GRUB menu ( ! ) ( I've never used Grub on my system ). When I select Ubuntu, the start-up process starts, but I get the error:

4.129466 i8042: no controller found

What is my problem? And how do I fix it?

4

Do you have an AMD graphics card? If so, were you using the fglrx drivers? There has been an issue with them lately on this new update, as some packages needed for the driver to work correctly weren't updated to Utopic. In this case, open up tty1 (Terminal 1) by hitting the keys Ctrl + Alt + F1, log in with an account that has sudo privileges and run:

sudo apt-get remove fglrx-*

This should solve the black screen problem.

8
  • Unfortunately it does not work. – Daniele Semeraro Oct 26 '14 at 8:35
  • It does work! Now the screen is very large and I can't see my entire desktop, but now it works! I'll let you know if I have any more problems. Thank you very much! (sorry for my previous entry) – Daniele Semeraro Oct 26 '14 at 8:42
  • @DanieleSemeraro If you are still experiencing the large desktop, check: If you are not using any workspaces, and that your resolution is set to the correct value. – LukeTheRuler Oct 26 '14 at 12:36
  • Unfortunately I've made a big mess. Ubuntu upper menu and left dock not showing. I searched the internet for a solution and I unfortunately disabled INTEGRATED GRAPHICS in the CMOS. Now the pc turns on but I can't see anything on my tv attached via hdmi cable. Can you help me? I also opened the case, sconnected and riconnected the battery but nothing happens. I can't find a jumper that resets the CMOS. How can I solve this big problem? Thank you in advance for your help. – Daniele Semeraro Oct 26 '14 at 17:04
  • I am searching for a solution, for the time being, install up gnome-session-flashback via aptitude and use the Gnome Flashback Metacity in the lightdm screen. Use tty1 if you prefer in the case. – LukeTheRuler Oct 26 '14 at 21:37
0

Hi I followed this advice, got back graphical access, but error message indicated underlying conflicts. So then reinstalled xorg elements using Synaptic packager, now can use while waiting for update repairing fglrx install. Thanks, bob

0

If your problem is still not solved after more conventional suggestions from others, please try the following.

  1. Remove your hard drive and attach it to an external USB drive adapter case appropriate to its size and interface, ie SATA, or mSATA, etc.
  2. Attach it to another computer and try to instruct that computer to boot to your drive as though it were (and it is) an external usb drive.
  3. See if it boots correctly. If it does, it suggests that something related to your graphics card of your current PC is not entirely compliant with the drivers which were installed in the upgrade. Fortunately, you will have access to drive to undriver it either using apt commands or my preference, the Synaptic Package Manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.