0

14.04 boots fine on my laptop with secure boot enabled. Never had an issue with it. 14.10 will not. The laptop complains there is no boot disc available.

I have tried updating 14.04 to 14.10 without success. I have formatted the SSD and recreated the EFI partition (512MB), Swap (4096MB) and the root partition (200GB), formatted as normal to BTRFS.

A 14.10 USB installation stick will boot but but the SSD will not.

The BIOS settings are unchanged between versions.

I have now put 14.04 back on and all is well, but want to upgrade.

Can anyone help?

1
  • UPDATE - I have tried to use Boot-Repair on my machine. I tried from a USB key and also from a CD on an external drive. The same UEFI problems prevent it from loading as 14.10. However... I did manage to get it installed from the 14.10 live usb stick and created a report at, paste.ubuntu.com/8675538 which shows no MBR on the disc. Why is it missing? I compared against desktop and there is one on the disc there again with UEFI. Boot Repair won't fix. Can anyone suggest any other options?
    – markrich
    Oct 25 '14 at 18:59
1

this might be related to this bug on launchpad. If yes, you could fix it by

  • booting with refind
  • installing an older version of efibootmgr (or compile & install the latest).
  • re-create the bios entries with sudo update-grub
  • examine bios entries with efibootmgr -v. Assure, that there are no entries with the same key.

Hope, that helps!

1
  • This was exactly the problem. Thank you. I used point 4 from the thread and corrected the problem. The laptop now boots once more and I am happier.
    – markrich
    Oct 29 '14 at 20:52
0

This is a link to hardware 'certified' to work with Ubuntu. Samsung isn't even on the desktop or server list of hardware. If you got 14.04 to work it was just random good luck.

More specs on your laptop for other users.

Samsung is a pretty big provider of PCs, smartphones and tablets, I'm not sure why they aren't certified. Perhaps they just didn't ask.

14.10 is too new so they haven't gotten 14.10 to work with Samsung Series 9 in all cases. Here's a page about 14.04 working with the Series 9.

3
  • 13.10, 14.04 both worked. There are many people running Ubuntu on the Samsung Series 9 laptop as a search around the web shows. There was no reason to expect 14.10 should be any different. Rather than just indicating, bad luck, perhaps some ideas may be useful to examine, look at and track down the cause could be useful. Are the certificates for secure boot different on this release? Is BTRFS an issue given the way Ubuntu creates two subvols for the system? etc.
    – markrich
    Oct 25 '14 at 15:10
  • I searched Samsung.com for 'ubuntu' and not a single page popped up.
    – Bulrush
    Oct 25 '14 at 15:22
  • I don't think you're being very helpful or useful to a resolution to this question. Perhaps better to let someone else try.
    – markrich
    Oct 25 '14 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.