37

Is there any way to have the menu items on window menus always visible? I hate the whole hide and seek thing and have searched Google and here but I'm unable to find anything on how to make them stay visible all the time.

Thanks

55

16.04 and later (Unity 7)

In addition to the gsettings option introduced in 15.04 (below), this same capability has been added to the Settings - Appearances window (click the gear icon top-right of the screen)

enter image description here

14.04, 15.04, 15.10

15.04 now has the ability to toggle the global menu as well as the local integrated menus (Via System Settings - Appearance - Behaviour tab) to be permanently on or off.

If you are running a fully up-to-date version of 14.04, this same ability has been backported.

To switch on permanently:

gsettings set com.canonical.Unity always-show-menus true

To switch off i.e. to autohide:

gsettings set com.canonical.Unity always-show-menus false
  • Thats the one buddy :) 'gsettings set com.canonical.Unity always-show-menus true' I'd already done the appearance setting change. Is it possible to still have it display the windows name though? – Jamie Hutber Mar 21 '16 at 11:41
9

Go to Ubuntu software centre and download a tool named Unity tweak tool

If it's downloaded, launch it and choose Window controls menu from there. Unity tweak tool In there, click on show menu button, and close the tweak program. enter image description here Reopen all windows and it should be working.

Also, please let me know if it did not work!

  • 8
    Ubuntu 14.04 here and it didn't work =| – MaikoID Feb 10 '15 at 13:18
  • 3
    Not sure maybe something has been changed with the feature. If I turned it on my self, then the menu is shown only when you open a new application and it is shown only for a couple of seconds. After that it dissapears. Without the option, the menu will not show at start, you have to mouse over. You could make a bug report about it I guess. – Kaspar Feb 10 '15 at 15:10
  • 2
    Hmm, interestingly the combination of two answers worked for me on Ubuntu 14.04 LTS. Besides doing what this answer suggests I also did what @fossfreedom says below, i.e. : gsettings set com.canonical.Unity always-show-menus true (which worked without complaining that 'No such key '). I tried two apps after doing this, Pidgin and Thundebird, and both of them had the Locally integrated menus permanently visible after restarting them. Before doing the gsettings bit from command line I had the same behaviour as described by @Kaspar in the comment above. – Ashutosh Jindal Jun 15 '15 at 14:37
  • 1
    gsettings and this one doesnt work in 14.04. – xamiro Nov 8 '15 at 17:41
  • Hi Kaspar, I did what you explained here but it didn't work for me - After checking "Right" and "Show menu button" no change is seen (Ubuntu 15.10). – JohnDoea Mar 8 '16 at 4:16

protected by Community Jun 11 '17 at 6:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.