2

I find my dropbox auto adds itself to startup programs, even after I unchecked it from the startup prefrences. However, when I manually started dropbox sometime, it automatically added itself to startup. Here is the experiment I did. (Ubuntu 14 LTS)

  1. Uncheck dropbox from startup.
  2. Exit dropbox
  3. Manually start dropbox
  4. Then dropbox is checked in the startup.

How to disable a program (e.g., dropbox) adding itself to startup programs?

5

The startup preferences is stored at ~/.config/autostart/. Take dropbox for example, it auto adds itself to startup by adding/editing the ~/.config/autostart/dropbox.desktop file. So a simple solution change that file and make it root-editable only.

  1. vim ~/.config/autostart/dropbox.desktop. Then change Exec=dropbox start -i to Exec=
  2. chmod 600 ~/.config/autostart/dropbox.desktop. This makes the file only accessible by its user.
  3. sudo chown root:root ~/.config/autostart/dropbox.desktop. This changes the user of the file to root.
-1

Changing preferences to prevent dropbox changing login items is good.

Yet simpler is changing dropbox preferences and deselecting "Start dropbox on system startup".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.