I just finished backing up my system and when I try to upgrade to Utopic Unicorn, I get the error "Cannot Calculate the upgrades." I ran the upgrade by sudo apt-get dist-upgrade, sudo do-release-upgrade after the GUI method failed, they all gave the same error.

The feedback gives some recommendations:

This can be caused by: 
* Upgrading to a pre-release version of Ubuntu 
* Running the current pre-release version of Ubuntu 
* Unofficial software packages not provided by Ubuntu 

I am not upgrading to a pre-release version nor coming from one, I'm going from Ubuntu 14.04 LTS to 14.10. I have no broken packages and I have unchecked all my non-official software sources in the 'Software & Updates' manager.

My guess left is the Unofficial software packages not provided by Ubuntu. If anyone could give any help as to how to check for unofficial packages using Synaptic or another, my appreciation.

Are there any other factors that may be causing this error and how would I go about checking/fixing those?


Edit: I have no broken or held packages. Everything is up-to-date, and restarting everything or anything has no effect.

  • I'm not the kind of guy who likes to think his desktop is for getting things done, I will always try to make modifications and break stuff in interesting ways. New features trump nearly every benefit, just cause I want to experiment with them. Commented Oct 30, 2014 at 1:22
  • very good robobenklein, I am sure you are doing well. As I can see you are German or your language is German because of klein in your username. So, Ich hofe, alles geht in beste Weg für Sie.
    – Sushiant
    Commented Nov 2, 2014 at 10:05

7 Answers 7


Try executing:

grep ERROR /var/log/dist-upgrade/main.log

Hopefully this will show you the names of conflicting packages. For me it was (I broken long line to be easier to read):

2014-10-25 18:15:05,915 ERROR Dist-upgrade failed: 
    'The package 'postgresql-9.3-postgis-2.1' 
    is marked for removal but it is in the removal blacklist.

postgresql-9.3-postgis-2.1 is conflicting package here. It will probably be different one or some for you. You can then remove it/them by:

sudo apt-get remove conflicting-package-1 conflicting-package-2 ...

Then just restart distribution upgrade.

  • I don't get any results mentioning any packages, just a fairly generic "Resolve Generated Breaks, this may be caused by held packages." Commented Oct 26, 2014 at 3:20
  • I think you can list held packages with dpkg --get-selections | grep hold and try removing them. I haven't been down this path though.
    – Suor
    Commented Oct 26, 2014 at 11:05
  • You can also unhold a package by sudo apt-mark unhold package_name.
    – Suor
    Commented Oct 26, 2014 at 11:09
  • I don't have any held packages, I only found "install" or "deinstall". All of the "deinstall" listed packages are just that - not installed. They've got residual configs, which I'll remove then try again. Commented Oct 26, 2014 at 15:41
  • No progress still. All my packages are clean, none broken, none held, none orphaned. The error specifically said "unofficial packages" and I'm not quite sure what that implies. Could it be handwritten modifications to a package? I've got plenty of those. Commented Oct 27, 2014 at 12:33

I managed to solve it by switching to main server in the ubuntu upgrade dialog box. Previously it was pointing to US

  • Your answer would be much improved if you would explain where to find said "ubuntu upgrade dialog box" and how to switch it so that the novice user could follow it. @Seth I noticed you didn't upvote it. I'm sure you'd agree that it could use improvement even if you qualify it as an answer. I beg to differ, to me this looks like a comment.
    – Elder Geek
    Commented Jun 11, 2015 at 12:33

I found that "broken" packages were causing problems with the upgrade. My packages (gnuplot) weren't explicitly broken (checked by looking in Synaptic package manager), but were marked to not be upgraded. This type of package will also cause the upgrade to crash; they can be found in the Synaptic package manager by filtering for "Installed (upgradeable)". I simply marked them for deletion, then ran

sudo apt-get dist-upgrade
sudo do-release-upgrade

... so far so good!


So I managed to solve the issue, but I am unaware as to how I did so. If you have any idea, I'd still like to know what it is I did that caused the resolution.

Here's exactly what I did.

I ran dist-upgrade and apt-get update/upgrade like a madman, continuously checking my broken and held packages in synaptic, of which I never had any. I had a few leftover packages like ROS libraries which I removed because I didn't want them anyways.

After a two days of waiting, I decided to look at the question referenced to by https://askubuntu.com/users/342922/user342922 . I peered into /var/log/dist-upgrade/apt.log and after seeing some reference to the ROS Libs I removed, I deleted that log file.

Only after I deleted that log file did dist-upgrade ever work. Any Ideas as to why this may have occurred? If prompted I'll move this to a new question, but it's not a pressing matter, just interested.

My odd solution: delete the apt.log file for dist-upgrade.


I had the same issue, though none of the logs listed anything about broken pages (nor did any output from apt-get).

The solution was to change the mirror that I was downloading my updates from. I typically use a local mirror here in Australia for speed, but it almost-always causes issues during upgrades due to either outdated packages or missing content.

My computer was apparently fully up-to-date, but after I switched my mirror to the Main server and ran:

sudo apt-get update && sudo apt-get dist-upgrade

several new packages got updated. After running update-manager, my Ubuntu 14.04 is was able to correctly upgrade.

  • Thanks for the info, it may also have been that my mirror updated a day late. Commented Oct 28, 2014 at 13:05

After fiddling a while with the different suggestions, what worked for me was commenting the multiverse entries in /etc/apt/sources.list.

  • Welcome to AU :) It would be nice if would explain some more how to do that. Click on the edit below your answer change it.
    – MadMike
    Commented Oct 31, 2014 at 7:14
  • A lot of information is missing from this answer. E.g. Why does commenting the multiverse entries fix the problem? Do you have to uncomment them afterwards?
    – Dennis
    Commented Nov 2, 2014 at 15:28

Try remove xserver-xorg-video-all.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .