I use transmission to download torrents to /media/serier/ (so not my home folder). I did this before and it worked, but after formating my drive to ext4 I get a permissions error. This is what I get from ls -la in /media/serier/serier/:

drwx------   2 user user       4096 2011-03-30 19:32 folder.name

And I believe that transmission is run by me (user).

ps -ef | grep trans
user     26076     1  0 00:23 ?        00:00:56 transmission-gtk

How do I fix this? Change the permission for the folder?

UPDATE: ok, I have changed permission to several folders now, but it still does not work. Here it is:

drwxr-xr-x   7 root root  4096 2011-07-21 22:26 media
drwxr-xr-x  5 user user  4096 2011-07-22 14:02 serier
drwxr-xr-x 103 user user 12288 2011-07-20 22:25 serier

(attempting to download a episode of Alphas)

/media/serier/serier/Alphas season 1/
drwxr-xr-x   3 user user       4096 2011-07-14 20:27 Alphas season 1

I still get this error message:

Error: Permission denied (/media/serier/serier/Alphas season 1/Alphas.S1E02.720...)

Every folder is owned by me (user) except for media owned by root and every folder is set to drwxr-xr-x. Why do I still get an error message?!


Changed the download location to:

drwxr-xr-x  3 user user   16384 2011-07-22 18:21 Downloads

and it works, but I don't want to download it to my home folder and move the file every time I download something..

Thanks for the fast response by the way..

  • 2
    Check permission of the folders too! (/media /media/serier/) – Rinzwind Jul 22 '11 at 12:35

I suspect that /media/serier is owner by root and its permissions are 700 (rwx------). With those permissions, only root can descend into the folder. You need to set the execute bit on the folder, so you can enter it. To do so, execute:

sudo chmod o+x /media/serier

The previous command sets the permissions from 700 to 701 (rwx-----x). Now you can descend into it, but not read the folder as a regular user. That might be annoying if you use a file browser to get into that folder, so I recommend to set the read bit too. Of course, it does not make sense to grant the world more permissions to the group, so set the same bits for the group too:

sudo chmod go+rx /media/serier

The permissions will be set from 700 to 755 (rwxr-xr-x) and you can now descend into the directory and list the contents of it.

  • I found a solution. I changed the permission to "drwxrwxr-x", not "rwxr-xr-x" or "drwxr-xr-x", but close. Thank you for your help – ganjan Jul 22 '11 at 16:35
  • Actually, the d in the output of ls -l is the type of the file, in this case a directory. – Lekensteyn Jul 22 '11 at 21:01

An incompetent sysadmin would simply chmod 777 everything till it worked. (Don't do that)
Make sure that everything previous folder.name is either 755 or owned by you.

In case you don't know what 755 means..
(755 == rwxr-xr-x), note that directories need execution in ordered to be ls'ed.
Look at http://en.wikipedia.org/wiki/File_system_permissions#Octal_notation

If this doesn't help, we're going to need to see an error message to diagnose further.


I just found out an issue that if u are using USB Drive or Network Drive. It must be a permission issue on mounting them. You can check uid/gid on your etc/fstab

In my case, I only need USB for storing my download files, so I mount them with uid=debian-transmission,gid=debian-transmission and it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.