I have upgraded from Ubuntu Gnome 14.04 to 14.10 yesterday using standard Software Updater GUI. The upgrade went smooth, however once upgrade was done I've noticed significant desktop performance degradation only when certain applications are running at the time. Basic desktop operations like switching between workspaces is accompanied by visible lag and stuttering, which is extremely annoying and disruptive in daily workflow.

I've recorded a screencast demonstrating this problem - I've used standard Image Viewer application (ver. 3.12.2) and Google Chrome as example apps causing this issue - which is not to say that these are ONLY applications causing it.

The screencast video: https://www.youtube.com/watch?v=0LhKhdgKHiQ

I've googled around this issue and tried several workarounds related to GPU's hw acceleration, yet none of these attempts fixed the problem.

Any help or pointers would be much appreciated.


As suggested in the comment below, I've executed glxinfo to gather additional graphics/acceleration data, however I don't have a clue how to read this: http://pastebin.com/JRuTgQSa

Additionally, I've filed a bug report in Launchpad: https://bugs.launchpad.net/ubuntu-gnome/+bug/1385764


If you have Integrated Intel graphics, you could try

sudo apt-get install xserver-xorg-video-intel

then rebooting. This worked for me on a Dell XPS laptop - everything became smooth again. Source: https://bugs.launchpad.net/ubuntu-gnome/+bug/1385764

If you subsequently have problems with

optirun glxgears

giving "Can't open secondary"...


 sudo apt-get install nvidia-331-updates


 gksudo gedit /etc/bumblebee/bumblebee.conf

Under the section [bumblebeed] change the Driver: Driver=nvidia

Under [driver-nvidia] change references in this section from nvidia-current to nvidia-331-updates. That's in the KernelDriver, XorgModulePath and LibraryPath.

Then reboot, and try

optirun glxgears

Source: http://mylinuxexplore.blogspot.co.uk/2014/03/solved-nvidia-cant-access-secondary-gpu.html


I fixed a similar issue by switching my gpu acceleration method from 'sna' to 'uxa'. See https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues

If you are experience issues with SNA, try using UXA instead, which can be done by creating an X configuration file containing the following: /etc/X11/xorg.conf.d/20-intel.conf Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "uxa" EndSection
  • 1
    Welcome to AskUbuntu, could you please explain the essential parts from the link in your answer? The internet changes and if the content on the link is changed or removed then your answer will help no one. It is better to explain how to solve the issue directly in AskUbuntu and leave the link as a source. Mar 22 '15 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.