17

I am using Ubuntu 14.10 64bit and the latest version of VLC media player, when I play a video (MP4, MKV AVI etc... it doesn't matter) at the bottom of the screen there is a green lineenter image description here
It isn't an issue with my OS, YouTube, and the default media player work fine. Has anyone else had this issue? and if so is there a fix or is it just a software bug?

4
  • This looks similar to the green lines that VLC renderes at the lower or right border when the video stream has an odd resolution. – LiveWireBT Oct 24 '14 at 18:05
  • Standard 1280x720 in an MKV container. – GhostMotleyX Oct 25 '14 at 16:45
  • 1
    This may be related to hardware accelerated video decoding and/or rendering. You can try to disable it in the settings in two places: on the “video” panel (called “Overlay video output”) and on the “input & codecs” panel. – David Foerster Oct 26 '14 at 15:04
  • Yep, that worked. Thanks. If you post that as an answer I will vote up your answer so you can get reputation – GhostMotleyX Oct 28 '14 at 23:20
21

Open vlc and then go to preferences > video > select in the output "X11 video output" (you can mess with this to find the one that works best for you).

That's it :P

0
13

Ctrl-P/Preferences/Video/Output.

Choosing OpenGL GLX Video output (XKB) should solve this problem.

enter image description here

At the same time, that change should also improve appearance of subtitles.

Before:

enter image description here

After:

enter image description here

A good idea might be also:

Tools menu -> Preferences -> Video -> Uncheck "Accelerated Video Output (Overlay") (as stated here.)

8

Open VLC
Go to Tools menu -> Preferences -> Video -> Uncheck 'Use hardware YUV-> RGB Conversons' Restart VLC

1
  • 2
    This should be the accepted answer, it fixes the problem without a performance loss. – Robin Clowers Jan 19 '17 at 23:33
4

Try the following options -

  1. Tools menu –> Preferences –> Video –> Choose OpenGL under Output options –> Restart VLC.

  2. Tools menu -> Preferences -> Video -> Uncheck "Accelerated Video Output (Overlay") -> Restart VLC.

6
  • Thank you. I have done the first step, but cannot find "Use hardware YUV>RGB conversions" to uncheck it for the second. So far, the green line has gone but the video is small and in bottom left corner. – Ben Moore Nov 16 '14 at 12:53
  • I have changed the second step accordingly. Try pressing c when the video is playing and let me know. – Rohith Madhavan Nov 16 '14 at 12:55
  • I'm afraid the video is still small and in the bottom left corner. Pressing c changes the shape but not the size. – Ben Moore Nov 16 '14 at 12:57
  • Ok. Instead of OpenGL try OpenGL GLX or something else in the Output options. – Rohith Madhavan Nov 16 '14 at 12:59
  • Selecting X11 Video Output in Output options may also do the trick. – Rohith Madhavan Nov 16 '14 at 13:10
-2

To get rid of green line at the bottom of VLC player!!

Minimize VLC and click on the extended settings tab. Click on the video effects tab Then click on the crop tab Then change the bottom setting to 1 All done green line is gone:)

1
  • This is not solving but hiding the problem! – Mostafa Ahangarha Mar 27 '16 at 8:13
-2

To get rid of green line at the bottom of VLC player , minimize VLC and click on the extended settings tab. Click on the video effects tab Then click on the crop tab Then change the bottom setting to 1 All done green line is gone:)"

And to get rid of the top green line just change the top setting to 2.

Not the answer you're looking for? Browse other questions tagged or ask your own question.