0

As I have searched for days and days online and couldn't find any solutions I decided to ask personally.

I have MSi CX620MX laptop and I just upgraded from Ubuntu 14.04 to 14.10

This is a laptop we got from a friend, it used to have finnish windows on it and sice we don't comprehend finnish that well we decided to just clean the laptop and intall ubuntu instead. When we got it it was still able to go online via wifi but it had a problem with the keyboard so we had to remove the built in keyoard with the finnish windows.

So ... now I have a laptop with Ubuntu 14.10 and no functioning fn+F8 button to turn on the wifi.

The computer claims the wireless is disabled by hardware switch. I also can't use bluetooth, perhaps these two problems are connected?

So I tried to follow some guide on how to install a driver but when running "lspci -nn -d 14e4:" I get nothing....

No idea what to do .. please help me to turn on wireless :(

4
  • This is a hardware problem, not a driver problem. hardware switch means a physical switch or button. A driver won't fix it.
    – user68186
    Oct 24 '14 at 16:34
  • Then what can I do to turn it on? as far as I have been looking the laptop itself it does not have a "button" or "switch" to turn on the wireless
    – user341944
    Oct 24 '14 at 18:33
  • What is the result of: lspci -nn | grep 0280 Thanks.
    – chili555
    Oct 24 '14 at 20:05
  • 06:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    – user341944
    Oct 26 '14 at 16:55
1

Maybe in 14.04 you had enabled a hardware driver and no longer needed in 14.10? Go to:

System Settings -> Software&Updates -> additional drives and "Do not use this device"

Worked for me )

1
  • 1
    The is nothing in the Additional Drivers tab... it is a big empty box with "No additional drivers avaivable." written in the center. "No proprietary drivers are in use. A proprietary driver has private code that Ubuntu developers can't review or improve. Security and other updates are dependent on the driver vendor." is written under the bow and I can click only "close"
    – user341944
    Oct 26 '14 at 17:01
0

Boot into the BIOS and you should find a setting that allows you to enable/disable the hardware switch, a check box for the wireless device you want controlled by the switch. This could be a physical switch such as a slide switch or a certain key combination such as Fn+F4. On my Dell I just cleared both boxes "Bluetooth and WiFi" and saved. Now it makes no difference what my "switch" is set to my radios are always on unless I turn them off in Ubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy