I'm currently running Windows 8.1 x64 (a problem in itself that I can't change sadly ;-P) with the latest version of VirtualBox (4.3.18 r96516). I managed to get the server version up and running with no issues but I cannot get the desktop version running.

I can boot to the menu and start the process (select the option to install and/or try) and it will get through the inital Ubuntu 14.10 loading screen (with the progess "bar/dots") but then we get to a nasty screen of distorted colors and that's it.

My hypothesis is that the display driver/server isn't working with VirtualBox and what I'm essentially seeing is the display in a crappy mode (16colors@62x24) because I am able to see a perfectly fine screen with cursor working and everything and then suddenly I'm in that nasty screen. The mouse does show up (nasty looking and filling the entire screen) but nothing else.

Here is a screenshot:

enter image description here

Here are my settings in an album (I can add more if desired but I put in what I thought were the most relevant):

enter image description here

enter image description here

enter image description here

enter image description here

  • Tell us what configuration have you made for that Ubuntu vm.
    – LnxSlck
    Oct 24, 2014 at 13:36
  • Updated post to include link to settings screenshot album. Here it is again for convenience: imgur.com/a/JGOlL.
    – MVit
    Oct 24, 2014 at 14:22
  • 1
    The 128 MB of memory did nothing. The solution provided by Gipnokote was the proper solution.
    – MVit
    Oct 24, 2014 at 16:03
  • 1
    Bug is logged here with VirtualBox: virtualbox.org/ticket/13615
    – Stéphane
    Dec 19, 2014 at 10:33
  • 1
    Same issue with Lubuntu 16.10. Enabling EFI was the only fix that worked for me: askubuntu.com/questions/852962/… Nov 24, 2016 at 5:02

5 Answers 5


Hit Right Ctrl+F1 (you will see the shell) and then Right Ctrl+F7. Depending on the Virtualbox configuration use Left Ctrl+Alt together instead of Right Ctrl.

You are good to proceed with the installation.

This works by forcing the kernel's graphics buffer / X / XRandR to re-detect the monitor and display in the proper resolution.

  • 18
    Alt+Ctrl+F1 is captured by the host. Using rightctrl+F1 and then rightcontrol+F7 works. Oct 25, 2014 at 15:58
  • I had a similar issue like this in the past and enabling 3D Acceleration and increasing the VRAM amount allowed me to install the OS. Nov 3, 2014 at 11:01
  • 7
    To work when using an OSX host, you must press Left Cmd + fn + F1 and then Left Cmd + fn + F7. Apr 3, 2015 at 20:31
  • 1
    For me <right_ctrl+f7> then <right_ctrl+f1> worked. nabling 3D acceleration and increasing VRAM did not help here.
    – rogerdpack
    Jul 22, 2016 at 3:46
  • Workaround succesful with same problem in Oracle VB 5. 2.12, lubuntu 18.04 LTS. Thanks!
    – Ignorante
    Jun 1, 2018 at 17:44

You need to switch between tty so the Guest GUI can refresh itself and detect the environment correctly. This is currently a minor bug.

I would suggest doing CTRL+ALT+F1 and then CTRL+ALT+F7 but if you are like me, this would be received by the Host and not the Guest.

The correct key combination to switch to tty1 while focusing on the Guest Window is:


followed by


Noticed that I am using the RIGHT CTRL which is the same one used by VirtualBox to escape focus of the VM.

Tested with:

  • VirtualBox 4.3.18
  • Host Ubuntu 14.10 64-bit
  • Guest Ubuntu 14.10 64-bit

Another way of making it work is like Whaaaat mentions. In the VM Settings, under the System section, activate the Enable EFI checkbox.

enter image description here

But also make sure your chipset is also set to PIIX3 since ICH9 will not work. It will leave you in a black screen.

enter image description here

When EFI is enabled, the boot process might take a little bit longer and the screen might stay black until the Ubuntu logo appears when booting. If you see Booting into secure mode right after starting the VM then you won't have any problems, if not, then wait a bit.

enter image description here

enter image description here

Note that I tested this with 32 MB of Video, 64 MB of Video and 128 MB of video. The video has nothing to do with the problem in either 32-bit or 64-bit.

  • @Whaaaaaat I am a ninja thief dude!!.. and also was testing your method which is good but if you can, add the Chipset issue with ICH9. Nov 3, 2014 at 16:08
  • 1
    For OSX host newbies (like me) the required key combination is fn+ctrl+alt+f1/f7
    – janih
    Jan 14, 2015 at 8:12
  • 1
    This worked perfectly. Thank you. After a wasted 20 minutes of failures this immediately worked, the first time. Thank you!!!
    – J-Dizzle
    Jul 25, 2015 at 18:06

Enable EFI mode.

enter image description here

When booting, you may see a few errors. However, these are harmless and do nothing to your system. It will still work.

When using EFI mode, make sure the chipset is set to PIIX3 mode, like in my picture. Having it on ICH9 is not fun. However, PIIX3 is the default, so you shouldn't have to set it.

Apparently Ubuntu and EFI now like each other, so they work together better than alone.

  • +1 For another great method.. will stea...borrow it. Nov 3, 2014 at 16:08
  • If EFI is enabled it seems that it does the initial prompt via a console menu, hence avoiding the (GUI and) problem. Nice!
    – rogerdpack
    Jul 22, 2016 at 3:49
  • Yes, but how does one proceed from there onward? That's the question.
    – KeyC0de
    Feb 9, 2017 at 11:23

I changed the chipset to ICH9, disabled nested paging. That solved it for me.

  • Works! Make sure you disable 3D acceleration and PAE/NX if you had enabled those.
    – totaam
    Nov 4, 2014 at 19:49
  • Didn't work here, I'm sad to relate.
    – rogerdpack
    Jul 22, 2016 at 3:51

I think is problem with 64 bit versions. At the same virtual machine the 64 bit doesn't work but 32 does. With 128M of video works fine the 64 bit one.

  • Hard to say but this doesn't address the issue. The work around was provided by Gipnokote.
    – MVit
    Oct 24, 2014 at 15:17
  • I'm sorry, I confused 14.04 with 14.10 that doesn't work with 128M os video memory. I'm sorry.
    – Think
    Oct 24, 2014 at 15:18
  • @Think Ubuntu 14.04 64-bit worked like a charm with 16 MB video memory in VirtualBox and aced 'em all with 128 MB video memory. But could not compete with Linux Mint.
    – retrixe
    Oct 25, 2014 at 19:27
  • Unfortunately for me (64-bit windows 10 host) 32 and 64 bit ubuntu seemed to exhibit the same failure...
    – rogerdpack
    Jul 22, 2016 at 4:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .