4

This morning I upgraded to 14.10 and Ubuntu itself will not load past the password stage. Tried Compiz and it says it cannot load... luckily Kubuntu seems to be working right now, but prefer the Unity dash and all that. So, what do I need to do so I don't break the other stuff and get back up and running? I know there are closed issues on other upgrades, but this is kind of stupid. If it helps, the computer has always upgraded and run as an I686 rather than the quad core, and I have never been able to get the AMD version to load on it. Thus all the info is for I386 systems. Thanks.

3

Try this: open terminal using Ctrl+Alt+T, or Ctrl+Alt+F1 and login

rm -rf .compiz-1

Ctrl+Alt+F7 #if you had used Ctrl+Alt+F1

1
  • 1
    And then? Nothing has changed. Why should this help me? – jimifiki Jan 4 '15 at 15:10
3

You should actually be deleting the folder at ~/.config/compiz-1 -- at least now under Utopic. DON'T delete the whole .config folder, just the /compiz-1 folder inside it (you can even use Dolphin if you enable 'Show hidden files' under > View.

There are also options like $unity-tweak-tool --reset that allows you to reset compiz, which is often the problem. (you will probably have to install it via apt. When it asks you if you want to proceed, type in the word yes in full, not just y).

That being said, I've uninstalled and reinstalled unity & compiz over various iterations, removed config files etc., but to no avail. It's since I installed kubuntu and there have been a few kernel upgrades as well, so it's hard to say where the fault lies, or the solution. Maybe I'll do a full reinstall when 14.10 is a bit settled, or else go back to Mint. [sigh]

2
  • I deleted the folder, nothing has changed – jimifiki Jan 4 '15 at 15:11
  • +1 for unity-tweak-tool --reset, it worked for me. – zaan May 3 '15 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.