5

On my network I have a file named : sftp://bernard@myserver.nl/home/bernard/shared/keepass2/algemeen.kdbx I want to use this file with Keepass2

In Nautilus I have mounted the directory successful and bookmarked it using the name : shared. The above filename I retrieved using Nautilus properties for path and filename.

If, within Keepass2, I try to open a file using network, the network directory is empty, although the network path is mounted and visible in Nautilus.

When opening Keepass2 I can no see the bookmarked entries, which is a pity. Is it possible to use Nautilus mounted files? network access via open file dialog shows it would work, but not for me.

So I used the Keepass2 function "open url" but without success. Keepass2 give me the message error : An error occurred performing a WebClient request." Because Keepass2 seems not to support sftp I tried again using : ftp://bernard@myserver.nl/home/bernard/shared/keepass2/algemeen.kdbx

Now I get the message : "Operation is not valid due to the current state of the object. But no application is using this file. I use Ubuntu version 14.04 and Keepass2 version 2.23 On older versions I could successful use a URL to open a file.

I tried to go to Nautilus, click right mouse click, and "open with Keepass". When done so I get again the message "Operation is not valid due to the current state of the object." So it seems the network file can be found.

It there a way to use the Keepass2 file on the network?

Then I tried once more, and now successful. The filename was altered to : /run/user/1000/gvfs/sftp:host=myserver.nl,user=bernard/home/bernard/shared/keepass2/algemeen.kdbx

No idea what happened, no idea why the user has the name of the file, but it works.

1
  • did anyone got an answer for that question 3 years after? Jan 4, 2021 at 14:22

1 Answer 1

1

I had the same problem on Ubuntu 20.04 In my experience KeePass2 isn't a good keepass client for Ubuntu. Instead go for KeePassXC which also has a nice plugin for the browser and a couple of android apps.

What works for me is saving my "vault.kdbx" file in a cloud storage. To access my vault on my mobile devices I use FolderSync to sync the file 2-way each 15 minutes (you can choose the time yourself)

Another solution is using an ftp-synchroniser to sync the "vault.kdbx" to your file system. This way KeePassXC (or KeePass2) kan open a file that resides in a "not-mounted-folder"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.