We're running Ubuntu 11.04 on quite a few Dell machines, but I am noticing that on some of them (including mine) Ubuntu freezes on randomly.
Normally when the screen goes to lock mode and you press a key to wake it up, this will happen.

Only mouse cursor can be moved but nothing else can even be clicked.
The only way out is to either go to terminal with CTRL + ALT + F1 key and re-login, or do a hard shut down.

Has anyone else also seen this happening?
What's the cause and solution/prevention!?

  • I'm having this same problem and none of the fixes work for me except using Alt+Ctrl+F1 and then sudo service gdm restart, and logging back in, or sudo reboot. I really hope this bug is fixed in 11.10.
    – KoRnKloWn
    Sep 4, 2011 at 21:10

2 Answers 2


I've seen this happen a few times. When it happened to me, it looked like Unity's compositing manager just stopped drawing the screen for some reason.

As an alternative to restarting my session, I switched to a terminal like you did, and then ran the following:

DISPLAY=:0.0 unity --replace

That got everything drawing again. It is possible that you could just blindly run unity --replace from the Alt+F2 prompt in this case too, but I haven't tried that.

I haven't done any investigation myself about the underlying cause though.

  • as far as i understand it's because of instability in compiz, restarting it doesn't help much though as you can get functionality back, but things are a bit broken after that and a restart is needed to get things running properly again Jul 22, 2011 at 7:10
  • 1
    I've had the system remain quite stable after restarting unity/compiz as described in my answer. I'm not convinced that the instability extends to a point that a system restart is required. Jul 22, 2011 at 7:47
  • sorry, i meant restarting compiz was unstable (using compiz -- replace), i haven't tried your method as i've gone over to the kubuntu side ;-) Jul 22, 2011 at 8:49
  • I am waiting for it to happen again, so that I can try your solution out..
    – Aman Alam
    Jul 22, 2011 at 9:10
  • Restarting unity or compiz (just kill it and it will spawn again) works for me and it is quite stable. Jul 27, 2011 at 13:44

I have noticed a similar behaviour. My problem was that certain folder that I tried to share did not have the correct permissions set.

This resulted in the ubuntuone-syncdaemon to utilise all the memory and cpu time.

Once I corrected the permissions to include the current user (myself in this case), everything worked like a charm.

I don't know to report this as a bug, so if somebody knows how to do it, please report it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .