21

Can't activate proprietary driver for NVIDIA from "Additional drivers" Ubuntu 14.04

I'm using Ubuntu 14.04,64 bit, with nvidia 610M dedicated graphics card.

By default when I go to "Softwares & Updates" > "Additional Drivers" it shows "Using X.Org X server-Nouveau display driver..." selected.

But I wanted to switch to proprietary nvidia driver so I selected "Using NVIDIA binary driver-version 331.38..." and clicked "Apply Changes" but shows a progress bar and after few seconds the "Nouveau" driver again shows selected.

I gave apt-get update from the terminal. Did a reboot after "Apply Changes" But still no luck.

It shows Nouveau driver ever after "Apply changes" and Reboot

6
  • What does sudo apt-get install nvidia-331 say?
    – muru
    Commented Oct 24, 2014 at 6:17
  • It listed out a bunch of packages for installation including nvidia. So why does it didn't get install when "Apply Changes" are clicked
    – nkg
    Commented Oct 24, 2014 at 7:44
  • Presumably some error occurs and it rolls back. Did you let the apt-get install run to completion?
    – muru
    Commented Oct 24, 2014 at 7:45
  • Same issue as you Nikhil. Did you resolve?
    – Layke
    Commented Mar 12, 2015 at 11:49
  • Did you try from a terminal the sudo apt-get --reinstall install nvidia-331 and look for errors.? I've had the "additional drivers" selection fail to completely build all the modules.
    – ubfan1
    Commented Jul 16, 2015 at 17:05

3 Answers 3

9

You can run this action from command line, using utility ubuntu-drivers. In this case you will get some helpful descriptions of error. To install the most appropriate version use ubuntu-drivers autoinstall

0
6

Under "Ubuntu Software" in the Software & Updates page set the Download From to be "Main Server"

This then lets you install the drivers...

enter image description here

You can then Install the Drivers for the Nvidia

enter image description here

1

I had the same issue, and the

ubuntu-drivers autoinstall

gave me some errors so I had to revome all the nvidia libs with the following commands

 sudo apt remove cuda
 sudo apt remove "nvidia*"
 sudo apt autoremove

and then I did as @Barafu Albino suggested.

1
  • Apart from cuda not being installed, this is what worked for me to get at lease decent resolution back, and allowing me to choose between drivers (I'm leaving them alone and not touching them now that they work on default "Using NVidia driver metapackage from nvidia-packag-390" (proprietary, tested)) Commented Mar 5, 2021 at 7:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .