3

So today the new Ubuntu release came out. I uninstalled my Nvidia drivers, made the upgrade and then installed the latest Nvidia blob from Xorg edgers.

Before the upgrade, my boot and shutdown splash was correct after following this thread: How to fix no splash screen in Ubuntu after nvidia proprietary driver installation

Now after the upgrade to Ubuntu 14.10, my grub conf is still the same, but Plymouth is now acting strange for some reason.

Here are 2 demonstrative videos so you guys could see the problem:

UPDATE: I am not sure why the videos don't play on the site it self, but they are downloadable too from the same link.

On the the first video, you can see that a lot of the logging that should happen behind the curtains, is for some reason displayed over my Plymouth splash theme. I don't think the regular desktop user should see this kind of stuff when shutting down their PC.

On the second video you can see that the Plymouth's splash screen comes up for a second then appears a black screen with some random Terminal text in the top, and then for a second you can see the Plymouth's loading dots in the middle in some very glitchy manner.

So what is up with this? Is this fixable and should I make a bug-report about this to Launchpad also?

EDIT: Also worth noting this quote from Plymouth's wiki:

Note that on Ubuntu, Plymouth is considered to be the "owner" of the console device (/dev/console) so no application should attempt to modify terminal attributes for this device at boot or shutdown.

As I understand it, no other application should interfere with what is displayed by Plymouth.

2

Have you tryed to reinstall the Plymouth from the drop shell, or enter in the terminal:

 sudo dpkg-reconfigure Plymouth

and you can also type in the terminal:

 sudo apt-get install --reinstall ubuntu-desktop

it might work fine this way.

4
  • It tells me that: E: Command line option --reconfigure is not understood when I run the first command? – Kaspar Oct 23 '14 at 22:54
  • And I also tried the reinstall option, still having the same problem. – Kaspar Oct 23 '14 at 23:04
  • 1
    @Michael, did you mean "sudo dpkg-reconfigure plymouth" ? – PJ Singh Oct 24 '14 at 4:47
  • @PJ Singh , tried it and it did not fix the problem also. – Kaspar Oct 24 '14 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.