1

when selecting the windows 8.1 boot option from the grub menu, all that happens is a black screen with a blinking cursor, windows never boots.

what i've tried:

  1. boot-repair
  2. testdisk
  3. windows specific instructions - (from windows live boot)
  4. deleting grub to force boot from first disk, first partition (where the windows install is located)

to no avail, nothing works. fyi: this has been working fine for the last nine months, upgrade ubuntu and windows won't boot.

the boot-repair log file is at http://paste.ubuntu.com/8643490

is there any interesting information contained here?

what else i can try?

1

As far as I can see you have 3 drives and there is no indication that you use UEFI booting or GPT partition tables (similar to what oldfred already posted in the comment above).

Windows 8 seems to be installed in sda1, but Grub installed in it's MBR. I don't recommend this, you should have the Windows boot loader in the MBR of this drive so that Windows can boot independently from Ubuntu if you select this drive from the BIOS menu to boot from.

  1. windows specific instructions - (from windows live boot)

I'm not sure what you mean, but running bcdboot C:\Windows\ /s C: from the installation media or another Windows 7/8/10 installation creates a new boot configuration in C: (change appropriately to your system if necessary, includes writing the bootloader, more info on the Technet page). Up until this point, there is nothing related to Ubuntu.

sdb1: __________________________________________________________________________

    File system:       Extended Partition
    Boot sector type:  -
    Boot sector info:

[…]

/dev/sdb5:The OS now in use - Ubuntu 14.04 LTS CurrentSession:linux
/dev/sda1:Windows 8 (loader):Windows:chain

This looks very odd. You have a non-bootable extended partition and therein the volume bootloader (or PBR) of Ubuntu. Please back up the Ubuntu installation and restore it to a primary partition (then run grub-install with the appropriate parameters or boot-repair to restore boot functionality). You should have no future issues related to this problem after you do this.

Related:

  • A little more on the disk/installation details: sda - SSD drive (60 Gb), sda1: Windows, sda2: Linux Swap and sda3: Ubuntu /boot. sda2 - 1Tb hard disk, two partitions, Ubuntu data. sda3 - 1Tb hard disk, Windows data. As for the grub entries, for whatever reason, boot-repair decides to put the grub directory to sdb5. This runs at boot, where OS selection then points to sda1 (windows) or sda3 (ubuntu). This has worked fine until upgrading to 14.04, so while it looks odd, I don't think it's actually a problem. But then, why does boot-repair decide to organize its data in this manner? – user312266 Oct 24 '14 at 17:13
0

I think it is something with the uefi partition... I have the same setup - used boot-repair to reinstall grub2.. after upgrade it didnt work the first 4 times using boot repair.... but on the last time randomly it worked.. all i have for you is to share my experience... when i initially installed ix on my system I made the efi partition double its default (windows formatted size) and put the ix efi file in that same partition.. i wasnt able to boot to windows from grub... i ran boot repair and it didnt work... same issue... i then ran boot repair and chose the advanced set up and used this link to help in "converting ubuntu to uefi mode" -- https://help.ubuntu.com/community/UEFI --- after this it worked great for months... after the last upgrade to 14 i had the same issue as you... so that is when i literally ran boot repair 4 or 5 time using recommended settings and eventually it was working...

  • also... currently from grub menu i can only boot windows from "windows boot mgr" - even though there are like 3 or 4 instances for win in the list. – gingamann Oct 23 '14 at 21:38
0

Thanks for the replies, here's my deeper understanding of the issue (as of this moment) and how I was able to solve it.

First, following the instructions from the following link, I was able to successfully get Windows to boot: https://superuser.com/questions/460762/how-can-i-repair-the-windows-8-efi-bootloader

However, grub was now disabled, making Windows boot directly on power reset.

Returning then to get Ubuntu back as a grub boot option, I:

  • boot from ubuntu live
  • install and execute boot-repair

Now when I rebooted the machine, grub menu returned as an option, allowing booting to Ubuntu.

But when I then choose Windows, the same problem from before has returned.

So, back to BIOS options, set my UEFI Windows Booter as boot preference before grub instance, power reset, and Windows again automatically boots.

The problem is (and a little googling seems to confirm this): Windows is UEFI and Ubuntu isn't, thus grub isn't either. It seems that grub cannot handle a non-UEFI OS and an UEFI OS in the same list.

Since Windows 8.1 cannot be non-UEFI, this means that my Ubuntu must be re-installed as an UEFI instance. I will eventually do this and confirm.

  • JFYI: You can boot an MBR installed Windows from a UEFI installed Ubuntu (answers suggesting that have been posted on this site) and I believe that the opposite is also possible when the GRUB and BCD are properly configured. I also recommend reinstalling the OS in UEFI mode. Please remember that a proper UEFI setup requires a GPT partition table and you would probably need to reinstall Windows too or convert the partition table. You can use DISM to backup and restore Windows. – LiveWireBT Oct 24 '14 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.