8

The Cinnamon desktop environment has a feature of showing "Recent Files", how can this feature be disabled?

closed as off-topic by Mateo, Pandya, Eric Carvalho, αғsнιη, Jan Nov 6 '14 at 12:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Mateo, Pandya, Eric Carvalho, αғsнιη, Jan
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Was this a Mint system (as tagged) rather than an Ubuntu system with Cinnamon installed? – Eliah Kagan Jan 1 '17 at 14:30
20

Nowadays you can pull up the menu, type 'privacy' and click on the 'privacy' icon that should appear. Turn off 'remember recently accessed files'.

The previous solution before this was introduced in the GUI was the below, which should now be redundant and left for curiosity only:


A simple hack to disable the feature:

  1. Remove the file containing a list of Recent Files: rm ~/.local/share/recently-used.xbel
  2. Create a new file that is completely empty: touch ~/.local/share/recently-used.xbel
  3. Change the attribute of this file to "immutable", meaning that it "cannot be modified, it cannot be deleted or renamed, no link can be created to this file and no data can be written to the file. Only the superuser or a process possessing the CAP_LINUX_IMMUTABLE capability can set or clear this attribute": sudo chattr +i ~/.local/share/recently-used.xbel
  4. The (empty) file is now immutable, meaning that the "Recent Files" feature is for all intents and purposes disabled, as no new list of recent files can be created.

Alternately:

  1. Create a folder named recently-used.xbel and set it read only.

Not the answer you're looking for? Browse other questions tagged or ask your own question.