0

I just did a fresh installation of Ubuntu 14.04. To not break anything, I created the default user during install, but I neither need nor want it. I added my usual users (UIDs > 10000), which work great.

Now I want to remove the user that I created during the installation from the greeter.

Using gdm I would usually put

[greeter]
Exclude = dummy

into /etc/gdm/custom.conf as described on the gnome homepage. When using lightdm, I would use its minimum-uid setting in /etc/lightdm/users.conf like this:

[UserAccounts]
minimum-uid=1001 #1100 10000 11000  <-- other attempts

as suggested here and reading the comments in users.conf this is also very intuitive.

However, it would seem gdm and lightdm couldn't care less about my configuration settings. The users set up on this system will change so I would rather use the facilities to exclude certain users, rather than keeping the display manager configurations up to date.

How can I make Ubuntu care for my display manager settings? Do I need to enable this somewhere?

I even went tried the Windows way of rebooting a few times ...

As a next step I will delete this default user, but I don't know if this has some side effects on the Ubuntu installation.

8
  • @MadMike: The problem "config files are ignored" occurs using two different DMs and I think this is odd. That's why I asked whether there is some Ubuntu specific configuration I must set before configuring gdm has any effect. Oct 23, 2014 at 16:52
  • I know that before lightdm was released gdm would honor the configuration. I don't know why that is.
    – MadMike
    Oct 23, 2014 at 21:21
  • The "default" user has no special meaning. Just be sure that you have another user with sudo rights and you will be good.
    – MadMike
    Oct 23, 2014 at 21:36
  • @MadMike: I'm such a rebel I even set a password for root. :-) I'll just delete that user then. Thanks! Oct 23, 2014 at 21:38
  • @user1129682 did you try the suggestion in the other answer? It was necessary for me, and even then only worked after a bug in accountsservice was fixed.
    – muru
    Oct 24, 2014 at 16:21

0

Browse other questions tagged or ask your own question.