1

I had just bought a toshiba l50-b-1q0 with intel wireless 3160AC module.

I have installed ubuntu 12.04 (I heard 14 natty is even worse) and tried different kernels: 3.12rc4, 3.11, 3.13.2, 3.17. But I have always the same problem. The wifi connection is either slow or keeps disconnecting, but the result is that it is unusable. I have also tried to use the iwlwifi from the backports release 3.16.1 and 3.13.2-1. Always the same problem. Also I have tried the use the firmware iwlwifi-3160-ucode-9, iwlwifi-3160-ucode-8, iwlwifi-3160-ucode-7 for the kernel 3.11, 3.13.2, 3.12rc4. No luck. I tried also to switch to wicd instead of the network-manager but still the problem is the same.

At the moment I do not know what to do and it is very frustrating. I have to say that I have similar problem with a brand new hp 15-n234sl with Realtek 8188ee wireless module. I thought that the problem was the Realtek chip and I changed it to the Toshiba because it has the Intel wireless module which should be better. I start to think there is a problem in Ubuntu with new wireless modules but nobody knows or understand it.

If you have any suggestion please help me.

At the moment modinfo iwlwifi returns:

filename:       /lib/modules/3.17.0-031700rc7-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
license:        GPL
author:         Copyright(c) 2003- 2014 Intel Corporation <ilw@linux.intel.com>
version:        in-tree:
description:    Intel(R) Wireless WiFi driver for Linux
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-7265-9.ucode
firmware:       iwlwifi-3165-9.ucode
firmware:       iwlwifi-3160-9.ucode
firmware:       iwlwifi-7260-9.ucode
firmware:       iwlwifi-8000-8.ucode
srcversion:     9D3A59AA6FB332EEE13056A
alias:          pci:v00008086d000024F4sv*sd00000030bc*sc*i*
alias:          pci:v00008086d000024F3sv*sd00000010bc*sc*i*
alias:          pci:v00008086d0000095Asv*sd00005490bc*sc*i*
alias:          pci:v00008086d0000095Bsv*sd00005290bc*sc*i*
...
alias:          pci:v00008086d00004232sv*sd00001201bc*sc*i*
depends:        cfg80211
intree:         Y
vermagic:       3.17.0-031700rc7-generic SMP mod_unload modversions 
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size_8K:enable 8K amsdu size (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable (default: 1) (int)
parm:           nvm_file:NVM file name (charp)
parm:           uapsd_disable:disable U-APSD functionality (default: N) (bool)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
parm:           fw_monitor:firmware monitor - to debug FW (default: false - needs lots of memory) (bool)

I have tried also the wireless_script you can find on the web so this is the result wireless-info.txt

    ======== Wireless-Info START ========

System-Info ~~~~~~~~~~~~~~~~~~~~~~~~

andrea-SATELLITE-L50-B 3.17.0-031700rc7-generic x86_64,  Ubuntu 12.04.4 LTS, precise

CPU    : Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz
Memory : 11936 MB
Uptime : 14:00:06 up 30 min,  4 users,  load average: 0.12, 0.17, 0.13


lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

07:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev 83)
    Subsystem: Intel Corporation Dual Band Wireless AC 3160 [8086:8170]
    Kernel driver in use: iwlwifi
08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
    Subsystem: Toshiba America Info Systems Device [1179:f920]
    Kernel driver in use: r8169


lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 002: ID 0b05:17ab ASUSTek Computer, Inc. 
Bus 002 Device 003: ID 8087:07dc Intel Corp. 
Bus 002 Device 004: ID 04f2:b446 Chicony Electronics Co., Ltd 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub


PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~



iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     IEEE 802.11abgn  ESSID:"Default"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: <MAC C-01 Default>   
          Bit Rate=1 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=26/70  Signal level=-84 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:111  Invalid misc:8703   Missed beacon:0



rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Interface        Soft blocked  Hard blocked
0: hci0: Bluetooth         no            no
1: phy0: Wireless LAN      no            no


lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

snd_soc_rt5640         93123  0 
snd_soc_core          207547  1 snd_soc_rt5640
snd_soc_rl6231         13037  1 snd_soc_rt5640
snd_pcm               105052  7 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_controller,snd_hda_codec,snd_soc_rt5640,snd_soc_core,snd_pcm_dmaengine
iwlmvm                249097  0 
mac80211              696913  1 iwlmvm
iwlwifi               190863  1 iwlmvm
cfg80211              514757  3 iwlmvm,mac80211,iwlwifi
wmi                    19379  1 toshiba_acpi


module parameters ~~~~~~~~~~~~~~~~~~

cfg80211      (2): 
iwlmvm        (2): 
iwlwifi      (13): 
mac80211      (5): 
snd_pcm       (2): 
wmi           (2): 


nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

State: connected (global)
==================o=============o=========o=============o=========o===========o==============o===========
 Interface & ID   | Type        | Driver  | State       | Default | Speed     | Support      | HW Addr   
==================o=============o=========o=============o=========o===========o==============o===========
 eth0             | Wired       | r8169   | unavailable | no      |           |              | <MAC eth0>
------------------+-------------+---------+-------------+---------+-----------+--------------+-----------
 wlan0  [Default] | 802.11 WiFi | iwlwifi | connected   | yes     | 1 Mb/s    | WEP/WPA/WPA2 | <MAC wlan0>

    *Default:        Infra, <MAC C-01 Default>, Freq 2437 MHz, Rate 54 Mb/s, Strength 36 WPA

    Address:         192.168.1.5
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1
    DNS:             192.168.1.1
------------------+-------------+---------+-------------+---------+-----------+--------------+-----------


NetworkManager.state ~~~~~~~~~~~~~~~
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true


NetworkManager.conf ~~~~~~~~~~~~~~~~

[main]
plugins=ifupdown,keyfile
dns=dnsmasq

[ifupdown]
managed=false


NM WiFi Profiles ~~~~~~~~~~~~~~~~~~~

Default              : ssid=Default | mac-address=<MAC wlan0> | ipv4=auto | ipv6=auto 
Default 1            : ssid=Default | mac-address=<MAC wlan1> | ipv4=auto | ipv6=auto 


interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~

auto lo
iface lo inet loopback


resolv.conf ~~~~~~~~~~~~~~~~~~~~~~~~

nameserver 127.0.0.1


Routes & Ping ~~~~~~~~~~~~~~~~~~~~~~

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     2      0        0 wlan0

--- 192.168.1.1 ping statistics ---
3 packets transmitted, 2 received, 33% packet loss, time 2009ms
rtt min/avg/max/mdev = 8.531/25.658/42.785/17.127 ms


iw reg get ~~~~~~~~~~~~~~~~~~~~~~~~~

(Region : "en_US.UTF-8")
country 00:
    (2402 - 2472 @ 40), (3, 20)
    (2457 - 2482 @ 20), (3, 20), PASSIVE-SCAN, NO-IBSS
    (2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
    (5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS


iwlist chan ~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     32 channels in total; available frequencies :
          Channel 01 (2.412 GHz) - 13 (2.472 GHz)
          Channel 36 (5.18 GHz)
          Channel 40 (5.2 GHz)
          Channel 44 (5.22 GHz)
          Channel 48 (5.24 GHz)
          Channel 52 (5.26 GHz)
          Channel 56 (5.28 GHz)
          Channel 60 (5.3 GHz)
          Channel 64 (5.32 GHz)
          Channel 100 (5.5 GHz)
          Channel 104 (5.52 GHz)
          Channel 108 (5.54 GHz)
          Channel 112 (5.56 GHz)
          Channel 116 (5.58 GHz)
          Channel 120 (5.6 GHz)
          Channel 124 (5.62 GHz)
          Channel 128 (5.64 GHz)
          Channel 132 (5.66 GHz)
          Channel 136 (5.68 GHz)
          Channel 140 (5.7 GHz)

          Current Frequency:2.437 GHz (Channel 6)


iwlist scan ~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     Scan completed :
          Cell 01 - Address: <MAC C-01 Default>
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=24/70  Signal level=-86 dBm  
                    Encryption key:on
                    ESSID:"Default"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000001704620565
                    Extra: Last beacon: 64ms ago
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK


blacklist ~~~~~~~~~~~~~~~~~~~~~~~~~~

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist rtl8192cu


modinfo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[snd_soc_rt5640]
filename:       /lib/modules/3.17.0-031700rc7-generic/kernel/sound/soc/codecs/snd-soc-rt5640.ko
srcversion:     CB68778F54B557A429DD977
depends:        snd-pcm,snd-soc-core,snd-soc-rl6231

[snd_soc_core]
filename:       /lib/modules/3.17.0-031700rc7-generic/kernel/sound/soc/snd-soc-core.ko
srcversion:     F61EC7151C3E99E2FD7908E
depends:        snd-pcm,snd-pcm-dmaengine,snd,snd-compress
parm:           pmdown_time:DAPM stream powerdown time (msecs) (int)

[snd_soc_rl6231]
filename:       /lib/modules/3.17.0-031700rc7-generic/kernel/sound/soc/codecs/snd-soc-rl6231.ko
srcversion:     72E2ED5916DFB5D4813CF01
depends:        

[snd_pcm]
filename:       /lib/modules/3.17.0-031700rc7-generic/kernel/sound/core/snd-pcm.ko
srcversion:     DFD3D904BAB36EBAEBF16D1
depends:        snd,snd-timer
parm:           preallocate_dma:Preallocate DMA memory when the PCM devices are initialized. (int)
parm:           maximum_substreams:Maximum substreams with preallocated DMA memory. (int)

[iwlmvm]
filename:       /lib/modules/3.17.0-031700rc7-generic/kernel/drivers/net/wireless/iwlwifi/mvm/iwlmvm.ko
version:        in-tree:
srcversion:     FDB8EF7B15064AB7B96EDF7
depends:        iwlwifi,mac80211,cfg80211
parm:           init_dbg:set to true to debug an ASSERT in INIT fw (default: false (bool)
parm:           power_scheme:power management scheme: 1-active, 2-balanced, 3-low power, default: 2 (int)

[mac80211]
filename:       /lib/modules/3.17.0-031700rc7-generic/kernel/net/mac80211/mac80211.ko
srcversion:     50BFD5A22F2717F72E28E1A
depends:        cfg80211
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[iwlwifi]
filename:       /lib/modules/3.17.0-031700rc7-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
version:        in-tree:
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-7265-9.ucode
firmware:       iwlwifi-3165-9.ucode
firmware:       iwlwifi-3160-9.ucode
firmware:       iwlwifi-7260-9.ucode
firmware:       iwlwifi-8000-8.ucode
srcversion:     9D3A59AA6FB332EEE13056A
depends:        cfg80211
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size_8K:enable 8K amsdu size (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable (default: 1) (int)
parm:           nvm_file:NVM file name (charp)
parm:           uapsd_disable:disable U-APSD functionality (default: N) (bool)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
parm:           fw_monitor:firmware monitor - to debug FW (default: false - needs lots of memory) (bool)

[cfg80211]
filename:       /lib/modules/3.17.0-031700rc7-generic/kernel/net/wireless/cfg80211.ko
srcversion:     A189C096E57D9F63A205933
depends:        
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

[wmi]
filename:       /lib/modules/3.17.0-031700rc7-generic/kernel/drivers/platform/x86/wmi.ko
srcversion:     2E987FE96F7EBB6BFC7E2B2
depends:        
parm:           debug_event:Log WMI Events [0/1] (bool)
parm:           debug_dump_wdg:Dump available WMI interfaces [0/1] (bool)


udev rules ~~~~~~~~~~~~~~~~~~~~~~~~~

# PCI device 0x10ec:/sys/devices/pci0000:00/0000:00:1c.3/0000:08:00.0 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x8086:/sys/devices/pci0000:00/0000:00:1c.2/0000:07:00.0 (iwlwifi)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC wlan0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

# USB device 0x0b05:0x17ab (usb)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC wlan1>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan1"


Custom files/entries ~~~~~~~~~~~~~~~

/etc/modules        : Default
/etc/rc.local       : Default
/etc/modprobe.d     : Default
/etc/pm/(cnf|pw|sl) : Default


Kernel boot line ~~~~~~~~~~~~~~~~~~~

BOOT_IMAGE=/boot/vmlinuz-3.17.0-031700rc7-generic root=UUID=e758ec89-625a-4515-9969-028465cd807a ro quiet splash vt.handoff=7


dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[    0.032369] Initializing cgroup subsys net_cls
[    0.032376] Initializing cgroup subsys net_prio
[    0.620306] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[    0.620781] audit: initializing netlink subsys (disabled)
[    1.184620] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    5.735860] wmi: Mapper loaded
[    6.431490] iwlwifi 0000:07:00.0: irq 49 for MSI/MSI-X
[    6.535493] iwlwifi 0000:07:00.0: Direct firmware load for iwlwifi-3160-10.ucode failed with error -2
[    6.535497] iwlwifi 0000:07:00.0: Falling back to user helper
[    6.640417] iwlwifi 0000:07:00.0: loaded firmware version 25.222.9.0 op_mode iwlmvm
[    7.379896] iwlwifi 0000:07:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164
[    7.379942] iwlwifi 0000:07:00.0: L1 Disabled; Enabling L0S
[    7.380156] iwlwifi 0000:07:00.0: L1 Disabled; Enabling L0S
[    7.617831] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[   12.498578] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   14.054253] iwlwifi 0000:07:00.0: L1 Disabled; Enabling L0S
[   14.054470] iwlwifi 0000:07:00.0: L1 Disabled; Enabling L0S
[   14.065086] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   14.119883] r8169 0000:08:00.0: Direct firmware load for rtl_nic/rtl8168g-2.fw failed with error -2
[   14.120838] r8169 0000:08:00.0 eth0: unable to load firmware patch rtl_nic/rtl8168g-2.fw (-11)
[   22.496297] wlan0: authenticate with <MAC C-01 Default>
[   22.498622] wlan0: send auth to <MAC C-01 Default> (try 1/3)
[   22.500202] wlan0: authenticated
[   22.500320] iwlwifi 0000:07:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
[   22.500323] iwlwifi 0000:07:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[   22.500325] iwlwifi 0000:07:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[   22.500639] wlan0: associate with <MAC C-01 Default> (try 1/3)
[   22.503785] wlan0: RX AssocResp from <MAC C-01 Default> (capab=0x451 status=0 aid=2)
[   22.504601] wlan0: associated
[   22.504636] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

    ======== Done ========
1

just an update for everyone using the Intel Wireless 3160ac (and also 7260 I guess). Reading from the bug report: https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1354975

I switched on Ubuntu 14.04 and installed the Kernel 3.13.0-37_3.13.0-37.64+iwlltr0001 from: http://people.canonical.com/~sforshee/iwl-ltr/trusty/

then I installed the last iwlwifi from backports3.16-1 and the intel firmware iwlwifi-3160-9-ucode.

After that, I typed in a terminal:

$echo "options iwlmvm power_scheme=1" | sudo tee /etc/modprobe.d/iwlmvm.conf
$echo "options iwlwifi bt_coex_active=Y swcrypto=1 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
$sudo reboot

At the moment, after more than 3 hours of testing (navigating continuously), the wifi connection is steady (no disconnections), not as fast as it should be, but it seems usable. If you have any idea about how to improve the connection please tell me.

I hope someone will find this post useful.

  • I added the options to /etc/modprobe.d/iwlwifi.conf that ai20 specifies and it does fix it on 14.04.2 LTS but it also disables 802.11n and limits you to 802.11g which is far from ideal. – galatians Apr 15 '15 at 19:35
1

I had a problem similar to this. I downloaded the firmware from here: http://wireless.kernel.org/en/users/Drivers/iwlwifi

And copied the .ucode file into /lib/firmware. After rebooting everything worked fine. I have linux-firmware and linux-firmaware-nonfree packages installed, but I think those may have older versions of the firmware.

Anyway, I hope this helps someone with a similar problem.

1

Using the "Intel Wireless 3160ac chipset", I was unable to associate with any AP (Access Point).

First I tried the patch above (disabling 11n) - but I didn't like this solution, as I was forces to use a lower bitrate.

After some extra research I found the problem - bluetooth. It is being addressed in the iwlwifi driver as the WiFi/BT co-exist problem.

==== FIX ====
[super easy] - disable the bt_coex_active flag:

echo options iwlwifi bt_coex_active=0 | sudo tee /etc/modprobe.d/iwlwifi.conf
  • Didn't work for me – vipin8169 May 16 '16 at 8:38
1

Try turning off bluetooth (with rfkill, for example).

I had a similar problem after upgrading from 14.10 to 15.04. I have a carbon X1, but it also uses iwlwifi. I fixed the problem by turning off bluetooth with rfkill. The page for the iwlwifi driver suggests that running wifi & bluetooth at the same time is difficult. I note that the script reports that your bluetooth is at least enabled.

There's some sort of iwlwifi driver parameters available for trying to make the two work together better, which you might explore if you actually need bluetooth. I have no use for it, so I just turned it off and everything was fine.

My guess at what happened to me: right after I installed 14.10, I removed a bunch of packages I didn't need. Possibly, one of these was bluetooth. Thus the problem never came up. Then when I upgraded, some sort of ubuntu-basic-packages-we-figure-everyone-will-want metapackage depended on bluetooth, so bluetooth was reinstalled, creating the problem. This seems like it could also have been what happened to you.

  • Thanks ! It works for me ! I have a Toshiba Portege Z30 with a Intel Corporation Wireless 3160 (rev 83) – PhE Jul 14 '15 at 12:01
  • The link is dead and you shouldn't post answers that do little more than refer to different questions. – David Foerster May 19 '17 at 2:13
  • Added text of deleted answer – Zanna May 19 '17 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.