12

I'm using ubuntu 14.04. I want to set acrobat reader as a default app for PDF files. Right clicking and going "open with" does not get me anywhere because app is not listed. not even under "other applications. Same thing with going through properties and selecting "open with".

I also tried doing it this way: going to /etc/gnome/defaults.list and change the line:

application/pdf=evince.desktop

to:

application/pdf=acroread.desktop

This just gave me an error and would not open PDF file at all. Please help.
I'm new to Linux and I'm not computer savvy.

10

Right click on the pdf file, then select Properties. In the Properties window, select the Open With tab. Find Acrobat Reader in the list of applications and select it, then press the button that says Set as Default. That should do it!

Here's an example of what that window looks like (it was taken from this How-to-Geek article):

enter image description here

9

This is what worked for me:

  • Open the file with

    sudo -H gedit /usr/share/applications/AdobeReader.desktop

  • Edit the Exec=acroread line to be Exec=acroread %f

  • Save the file as

~/.local/share/applications/AdobeReader.desktop

And Voila! Now you can see the Acrobat reader option when you right-click on the file. It'll also show in the properties > OpenWith tab.

  • 1
    no need to save as to other directory on Ubuntu 14. Just add %f as mentioned and save it. Then right click on PDF file > Properties > Open with, then Adobe reader is visible now. Thanks Luis. – Hesam Apr 21 '16 at 20:19
  • 4
    Actually, it should be %U rather than %f. The reason being that %f will only open a single file, while acroread is capable of opening several files at the same time, or indeed several URLs at the same time. – Gsxr1k Jun 25 '16 at 17:31
  • @Hesam Your way requires root privileges Luis's way doesn't. – UTF-8 Jan 24 '17 at 23:32
  • File doesn't exsist – Philip Rego May 14 '20 at 15:30
5

The default applications' list is saved in

/etc/gnome/defaults.list

You need sudo privileges to edit this file. So open it as:

gksudo gedit /etc/gnome/defaults.list

and then locate the line containing the following:

application/pdf=...

where ... represents the current default application. Replace it as:

application/pdf=acroread.desktop

and then save the file. Now you have acrobat reader as your default viewer!

  • this way you are changing the defaults system-wide which is not necessarily desired – rosch Jan 24 '17 at 23:28
  • Wasn't that the question though if I correctly understand? – Peaceful Jan 25 '17 at 4:12
  • Does not work for me. Do I have to restart something? – Alex May 2 '19 at 9:00
  • @Alex : What exactly happens? – Peaceful May 6 '19 at 10:25
  • Its fine, I figured it out. I needed to create a AdobeReader.desktop by hand, or similar. – Alex May 6 '19 at 11:13
3

It can happen that file is missing. In that case, add the following content to the file ~/.local/share/applications/acroread.desktop :

[Desktop Entry]
Name=Adobe Reader 9
MimeType=application/pdf;application/vnd.fdf;application/vnd.adobe.pdx;application/vnd.adobe.xdp+xml;application/vnd.adobe.xfdf;
Exec=/opt/adobe/Adobe/Reader9/bin/acroread %U
Type=Application
GenericName=PDF Viewer
Terminal=false
Icon=AdobeReader9
Caption=PDF Viewer
X-KDE-StartupNotify=false
Categories=Application;Office;Viewer;X-Red-Hat-Base;
InitialPreference=9

Now you should be able to right-click any PDF file and choose Adobe Reader 9 as your default PDF reader.

If for some reason Adobe Reader is still not to be found in the list, run the following command to set it as default reader:

for type in pdf x-pdf fdf xdp xfdf pdx ; do
    xdg-mime default acroread.desktop application/$type
done

This will modify the file ~/.config/mimeapps.list accordingly, at least on Ubuntu 16.04 that is.

Now hit F5 to refresh Nautilus and your PDF files will finally open with Adobe Reader.

3

I am on Ubuntu 18.04.3 LTS and had a similar problem with Adobe Acrobat Reader DC installed by snap. I tried to use @Luis's solution, so I tried to edit /snap/acrordrdc/6/meta/gui/acrordrdc.desktop but it was readonly and there was no success.

Eventually, I figured out that snap files cannot be edited manually because of security concerns described here. Fortunately the file /var/lib/snapd/desktop/applications/acrordrdc_acrordrdc.desktop is editable by root or sudoers. I edited the line starting with Exec= as follows:

Exec=env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/acrordrdc_acrordrdc.desktop /snap/bin/acrordrdc %f

I just added %f at the end of line and then Adobe Acrobat Reader DC was appeared in the "Open With" dialog.

enter image description here

0

Install tha application ubuntu-tweak by opening a terminal and typing the following command: sudo apt-get install ubuntu-tweak

After successful installation of ubuntu-tweak, open the application and choose admin panel, where you have to choose the option named "File Type Manager".

Now choose "Application". Here you can see that PDF document is associated to evince(Document viewer). Highlight this and choose edit.

Here if your application is not listed, choose add then choose "use a custom command". Here choose browse and locate your app exe and add. Then chose it in "Edit Type" menu.

You are done.

  • Why sudo su -? To have a dangerous root shell around? The second command is more than sufficient... – Rmano Oct 23 '14 at 8:13
  • Unable to locate ackage ubuntu-tweak – Alex May 2 '19 at 9:06
-1

Navigate to a PDF file with "Files", right click on the file and choose "Properties", choose the "Open With" tab in the dialog, choose your application, click on "Set as Default".

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.