I'm trying to install AVLD 1.4 on Natty.

I've unpacked the files, but when I compile them with make, it fails:

make -C /lib/modules/2.6.38-8-generic-pae/build M=/home/jmendeth/Downloads/avld_0.1.4 modules
make[1]: entering «/usr/src/linux-headers-2.6.38-8-generic-pae»
  CC [M]  /home/jmendeth/Downloads/avld_0.1.4/video_device.o
/home/jmendeth/Downloads/avld_0.1.4/video_device.c:23:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make[2]: *** [/home/jmendeth/Downloads/avld_0.1.4/video_device.o] Error 1
make[1]: *** [_module_/home/jmendeth/Downloads/avld_0.1.4] Error 2
make[1]: leaving «/usr/src/linux-headers-2.6.38-8-generic-pae»
make: *** [all] Error 2

I have tried to install libv4l-0 and libv4l-dev, but still the same error.
If I replace linux/videodev.h with linux/videodev2.h on the file, a lot of errors pop out.

Any ideas?

2 Answers 2


AVLD doesn't appear to be maintained anymore.

A similar video loopback package exists in the repositories which you can install - its called v4l2loopback-source.

Auto Install

First from a terminal, drop to a root shell

sudo su

If you havent installed kernel modules before with module-assistant run the following from a terminal

apt-get install module-assistant
m-a prepare
m-a update

Finally - download and install v4l2loopback

m-a a-i v4l2loopback

Manual Install

Download the package - once installed it can be found in /usr/src/v4l2loopback.tar.bz2

Copy the package to, for example your ~/Downloads folder compile and install

cd ~/Downloads
tar -xvf v4l2loopback.tar.bz2
cd modules/v4l2loopback
sudo make install
sudo modprobe v4l2loopback

This will create a /dev/video0 or /dev/video1 (etc) device.

  • 1
    Or install it with module-assistant. Jul 22, 2011 at 20:20
  • ... excellent pointer @jmendeth
    – fossfreedom
    Jul 22, 2011 at 20:45
  • Anyway, how can I get AVLD (and similar apps which use V4L1) to compile in Ubuntu? What am I missing? Jul 30, 2011 at 16:10
  • 1
    dont think you can - the v4l1 API was dropped with kernel 2.6.15. If you've got a v4l1 only app, have you tried the old trick LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so <appname> ?
    – fossfreedom
    Jul 30, 2011 at 16:22

linux/videodev.h is now in libv4l1-videodev.h, in 11.04 change this #include https://code.ros.org/trac/opencv/ticket/1047

  • 1
    Welcome to Ask Ubuntu. While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. Thank you.
    – Peachy
    Aug 23, 2012 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.