1

I just installed Kubuntu. The hardware includes two current generation ATI graphics cards in crossfire configuration. I have only one monitor plugged in. Kubuntu's Display and Monitor settings correctly identifies that I have only one screen; the multiple monitors section says so directly.

Nevertheless, when I move my cursor past the right edge of the screen, it can move what appears to be approximately one full screen width beyond my visible desktop.

I have also observed one program centering a message in a location that appears to be centered at the right edge of my screen, i.e in the middle of my actual monitor and the imaginary monitor.

I guess there are some settings somewhere, used only by the mouse and this one program, that thinks there is a second monitor. How can I fix this?

Edit to add xrandr output:

Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1280
DFP1 disconnected (normal left inverted right x axis y axis)
DFP2 disconnected (normal left inverted right x axis y axis)
DFP3 disconnected (normal left inverted right x axis y axis)
DFP4 disconnected (normal left inverted right x axis y axis)
DFP5 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 375mm x 301mm
   1280x1024      60.0*+   75.0     72.0     70.0  
   1280x960       72.0     75.0     70.0     60.0  
   1152x864       72.0     75.0     70.0     60.0  
   1280x768       72.0     75.0     70.0     60.0  
   1280x720       72.0     75.0     70.0     60.0  
   1024x768       72.0     75.0     70.1     60.0  
   800x600        70.0     72.2     75.0     60.3     56.2  
   640x480        70.0     75.0     72.8     67.0     59.9  
DFP6 disconnected (normal left inverted right x axis y axis)
CRT1 disconnected (normal left inverted right x axis y axis)

...and xorg.cfg

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen         "aticonfig-Screen[1]-0" RightOf "aticonfig-Screen[0]-0"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[1]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[1]-0"
    Driver      "fglrx"
    BusID       "PCI:2:0:0"
EndSection

Section "Screen"
    Identifier "Default Screen"
    DefaultDepth     24
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[1]-0"
    Device     "aticonfig-Device[1]-0"
    Monitor    "aticonfig-Monitor[1]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
4

I found an answer elsewhere. Just replace the top part of the xorg.conf with this. Basically placing the other screen disjointed removes the ability for the mouse to traverse edges:

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen         "aticonfig-Screen[1]-0" 2000 0
EndSection
2
  • If this solved your issue mark this answer as correct by clicking the check box of the left edge of it. – Bruno Pereira Nov 28 '11 at 0:32
  • Sure, I will, but it is an awfully ugly solution. – Adoring Gumdrop Nov 28 '11 at 10:45
1

I know that this is a very old thread but maybe it could still help someone like me who still has this problem even with Kubuntu 18.04 LTS. My laptop has a resolution of 1366x768 and I had the same issue.

In order to fix it just use the xrandr command as follows:

  • open a terminal and type xrandr | grep current to get your current (virtual) screen size (it should be higher than your real screen resolution);
  • get your real screen resolution in the Displays setting;
  • finally type xrandr --size yourresolution (where yourresolution is like 1366x768)

I hope that this will help someone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.